This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 19, 2019 at 10:45 am #4245853

federicoD-16

I am trying to: Update a page of a the second language running in a different domain. .com and .de for EN / DE.

Link to a page where the issue can be seen: All of them.

I expected to see: Updating page as usual.

Instead, I got:

Updating failed. Many errors in the console. The most common one

Failed to load resource: Request header field X-WP-Nonce is not allowed by Access-Control-Allow-Headers. wpml

I have followed the instructions for the multi-domain setup.

Everything is absolutely new and up to data. Requirements are met.

July 19, 2019 at 4:28 pm #4247497

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- This may be related to some cache on your site. Please follow these steps and tell me how things work after:

on your FTP, rename the .htaccess file to .htaccess-backup;
go to Dashboard → Settings → Permalinks;
hit the Save Changes button;
try again to do the setup.
If the problem persists, please disable all non-WPML plugins, switch to the default theme (like Twenty Nineteen) and see if you still have this issue.

Before doing all of this, please create a full backup of your website. This way you'll be able to roll back all the changes in case anything goes wrong (even though it shouldn't).

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

July 22, 2019 at 1:59 pm #4258215

federicoD-16

Dear Support,

I alredy tried that, however it did not affect the result.

I am not using any caching plugin and I activated server-side caching after the go-live on the site. The issue had been happening before though.

I hope the additional information helps narrow down the issue.

Best regards,

Alvaro

July 22, 2019 at 3:26 pm #4259501

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alvaro,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 23, 2019 at 4:19 pm #4267977

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alvaro,
Thank you very much for the information provided.

I visited the site but I wasn't able to reproduce the issue. I edited the page hidden link and updated the translation but I didn't see any error.

Could you provide the steps you are following in order to reproduce the issue.

Regards,
Carlos

July 23, 2019 at 4:27 pm #4268085

federicoD-16

Hello Carlos,

you need to edit the page of the secondary language, English.

For instance: hidden link

German works like a charm. English shows many errors when updating a page.

July 24, 2019 at 11:58 am #4274251

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I see that the issue is only happening if you try to save the page from the .com domain. If you edit the page in German (make sure you are in the .de domain) and then use WPML icon to translate the page you should be fine because you will always stay in the .de domain even if you are editing the content in English.

Could you confirm that following this steps the issue disappear?
Regards,
Carlos

July 26, 2019 at 7:29 am #4287917

federicoD-16

Hello Carlos,

thank you very much for taking time to look into this issue, I appreaciate taht.

I am not very familiar with the process you describe above, as I usually edit the page I am in with the admin bar on the page. The pages are independent and are being translated separately, therefore I am not sure if the process you mention would apply in this case.

Furthermore, I have enjoyed the feature of editing pages separately via WPML in Enfold and that is what I would like to offer to customers.

The workaround might be OK for me, but not acceptable for a customer who wants to do a small edit on the page by himself.

I would like to fully solve this issue.

Thank you,

Alvaro

July 26, 2019 at 11:31 am #4289433

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alvaro,

In order to solve this issue you need to follow this steps:
- Contact your hosting providers and find out if your server is Apache or Nginx.
- If Apache: Follow the steps described here or ask your hosting provider to do it: hidden link
- If Nginx just find this string: add_header X-Frame-Options "SAMEORIGIN";
and comment it or add the wildcard as with Apache

Note 1: If there is a security plugin, please to check the REST settings. plugins like ithemes allow you to block REST requests.

Note 2: If nothing works, the hosting providers should know what they block by default.

Best regards,
Carlos