This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 5 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 5, 2019 at 10:25 am #3742397

wan-hsuanC

I am trying to:
setting the language format > different language in directories > Use directory for default language >HTML file
I filled "/home"

Link to a page where the issue can be seen:
hidden link

I expected to see:
The page will redirect to /en or /zh-hant

Instead, I got:

Warning: include(/home): failed to open stream: Permission denied in /home/msangela/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/request-handling/redirection/wpml-rootpage-redirect-by-subdir.class.php on line 47

Warning: include(): Failed opening '/home' for inclusion (include_path='.:/usr/local/php71/pear') in /home/msangela/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/request-handling/redirection/wpml-rootpage-redirect-by-subdir.class.php on line 47

May 6, 2019 at 9:27 am #3746509

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

1)
These two should be same in Setting > General : hidden link

2)
Did you install the site/WordPress in a sub folder?
if yes, please refer : https://wpml.org/forums/topic/i-acitivated-de-as-default-language-subdirectory-and-en-as-english-translati/

3)
If you just leave it blank like this hidden link do you see the same issue?

4)
Most IMPORTANTLY you have to define a HTML file there if you want. Not just /home.
Please refer : https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Let me know how it goes.

Regards,

The topic ‘[Closed] failed to open stream’ is closed to new replies.