This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Juliette 6 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
April 11, 2019 at 8:14 am

Juliette

WPML is giving a fatal error:

Fatal error: Uncaught Error: Call to a member function get_external_repo() on null in /home/theland8/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php:2335 Stack trace: #0 /home/theland8/public_html/wp-includes/class-wp-hook.php(286): WP_Installer->setup_plugins_page_notices('') #1 /home/theland8/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/theland8/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/theland8/public_html/wp-admin/admin-header.php(276): do_action('admin_notices') #4 /home/theland8/public_html/wp-admin/plugins.php(459): require_once('/home/theland8/...') #5 {main} thrown in /home/theland8/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2335

All other plugins on our site are NOT available in the backend when WMPL is activated.

When I remove WPML the backend behaves normal. I tried to re-install and get the same problem again.

Can you help out?

April 11, 2019 at 8:51 am #3585287

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. Sorry for the trouble, this Plugins page issue has been escalated to our development team. We have a workaround that I am going to try in your site. Please wait and I will get back to you with my findings.

Thank you

April 11, 2019 at 8:58 am #3585311

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I logged into your site, followed these steps and the issue is gone now:

1. Activate latest WPML plugin.
2. Go to Dashboard -> Updates
3. Press the "Check again" button
4. Scroll to the bottom and press the "Update" button
5. Go to the Plugins page.

Please confirm, thank you

April 11, 2019 at 9:10 am #3585479

Juliette

Seems to work again. Thank you!!