This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by sarahK-19 2 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 29, 2019 at 4:01 pm

sarahK-19

I am trying to install WPML. I successfully registered the plugins, but it will not let me activate WPML Multilingual CMS. I am getting this message:

Fatal error: Cannot redeclare icl_get_home_url() (previously declared in /home/u751697530/domains/archicoders.com/public_html/salud/wp-content/plugins/polylang/modules/wpml/wpml-legacy-api.php:18) in /home/u751697530/domains/archicoders.com/public_html/salud/wp-content/plugins/sitepress-multilingual-cms/inc/template-functions.php on line 77

Uploaded plugins are attached.

website is salud.archicoders.com

July 29, 2019 at 4:13 pm #4301773

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, you have Polylang installed, too and we don't usually recommend the use of multiple multilingual plugins as that can create issues.

Can you please try this for the moment and see if it works:
- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if it made any change.

If it did not, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

PS: Just a note that I am at the end of my shift at the moment and I will be able to get back to you tomorrow.

If you would prefer to not wait for a ticket response, you can mark this current ticket as resolved and in the process of creating a new ticket, you can select the "Live chat" option (it should be the default method now).

Kind regards,
Mihai Apetrei

July 29, 2019 at 4:25 pm #4301877

sarahK-19

My issue is resolved now. Thank you!