This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by zsoltE-2 9 months, 4 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 5, 2019 at 2:53 am #4337433


Hello. My site says:

Error Details
An error of type E_ERROR was caused in line 102 of the file /var/www/html/unit-test-1/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-orders.php. Error message: Uncaught Error: Call to undefined function icl_get_string_id() in /var/www/html/unit-test-1/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-orders.php:102
Stack trace:
#0 /var/www/html/unit-test-1/wp-includes/class-wp-hook.php(288): WCML_Orders->get_filtered_comments(Array)
#1 /var/www/html/unit-test-1/wp-includes/plugin.php(251): WP_Hook->apply_filters(Array, Array)
#2 /var/www/html/unit-test-1/wp-includes/class-wp-comment-query.php(455): apply_filters_ref_array('the_comments', Array)
#3 /var/www/html/unit-test-1/wp-includes/class-wp-comment-query.php(346): WP_Comment_Query->get_comments()
#4 /var/www/html/unit-test-1/wp-includes/comment.php(242): WP_Comment_Query->query(Array)
#5 /var/www/html/unit-test-1/wp-admin/includes/dashboard.php(925): get_comments(Array)
#6 /var/www/html/unit-test-1/wp-admin/includes/dashboard.php(800): wp_dashboard_recent_comments()
#7 /var/www/html/unit-test-1/wp-admin/includes/template.php(1304): wp_dashboard_site_activity('', Array)
#8 /var/www/html/unit-test-1/wp-adm

August 5, 2019 at 9:58 am #4339603

Rohan Sadanandan

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


Thank you for contacting WPML Support.

The error appears to come from WooCommerce Multilingual - a plugin related to WooCommerce and a bridge that enabled the translation of WooCommerce via WPML.

You are using old versions of some of the WPML add-on plugins. I would like to suggest you to update all of the plugins that are related to WPML.

To temporary disable WooCommerce Multilingual(the plugin which gives the error for you now) you can go to /wp-content/plugins/ folder via FTP and rename the folder of woocommerce-multilingual to something else.
This should enable you to do all the changes and enable you to visit your frontend/backend if there are problems with this at this time.

After you finish updating all of the plugins you can rename back and re-activate all needed plugins.

Also, the WP Memory limit in your site is 40MB.
At least 128 MB is required for WPML. You can read the minimum requirements here:

Could you please update the same?
You can follow the steps in this link for updating WP Memory:

Also, make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).


August 8, 2019 at 2:13 am #4358907


My issue is resolved now. Thank you!