Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Nicolas 2 years, 2 months ago.

Assigned support staff: Bigul.

Author Posts
September 20, 2017 at 3:04 pm

Nicolas

I am trying to: Activate the newly downloaded WPML 3.8.1

I deleted the folder wp-content/plugins/sitepress-multilingual-cms, checked that everything else worked and then reinstalled via uploading sitepress-multilingual-cms.3.8.1.zip that I just downloaded from this site.

CENTOS 7.4 kvm v66.0.23
Apache 2.4 PHP 7
WordPress 4.8.1

Instead, I got:
Plugin could not be activated because it triggered a fatal error.

Fatal error: require(): Failed opening required '/home/site1/public_html/blog/wp-content/plugins/sitepress-multilingual-cms/menu/wpml-admin-scripts-setup.class.php' (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/site1/public_html/blog/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 120

September 20, 2017 at 4:14 pm #1378167

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nicolas,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Maybe it will be happening because of a compatibility issue. Please try the following steps after a full site backup and let me know your feedback.

1) Switch to 2017 theme for a moment
2) Deactivate all other plugins
3) Activate WPML and make sure you are still having the issues
4) If it is working fine, configure WPML
5) Then switch to your theme and reactivate other plugins. Then check you are still having the error or not

If you are still facing the issues, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue locally.

--
Thanks!

Bigul

September 20, 2017 at 8:37 pm #1378385

Nicolas

Bigul,
I did as you suggest and I still can't activate the WPML plugin. I get the same error.
Many thanks,
-Nicolas

September 21, 2017 at 6:21 am #1378601

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nicolas,

I made a duplicator copy of your site and then tried it on my local server. It is working fine without any issues and I can activate WPML. In past are you using WPML older versions of WPML on this site? Becuase when I activate WPML, it was already configured.

Please check the attached image and this screencast hidden link for more details.

After that when I activate WPML on your site, it is working. But I deactivated now.

Please check and let me know your feedback.

--
Thanks!

Bigul

September 21, 2017 at 7:52 pm #1379741

Nicolas

Bigul,
Well, I don't know what you did, but things are working now.
Many thanks,
-Nicolas