This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
When I install Translation Management I get this error:

Fatal error: Uncaught Error: Class 'WCCP_Settings' not found in /homepages/2/d604803240/htdocs/wp-content/plugins/woo-confirmation-page/includes/class-wccp-localization.php:67 Stack trace: #0 /homepages/2/d604803240/htdocs/wp-content/plugins/woo-confirmation-page/woo-confirmation-page.php(61): WCCP_Localization::_set_strings_to_translate() #1 /homepages/2/d604803240/htdocs/wp-includes/class-wp-hook.php(286): WCCP->init('') #2 /homepages/2/d604803240/htdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)

Solution:
It was another plugin causing incompatibility.

This topic contains 2 replies, has 2 voices.

Last updated by kaneC 1 year ago.

Assigned support staff: Noman.

Author Posts
October 11, 2018 at 1:40 am #2806117

kaneC

I am trying to:
Get rolling with WPML. I've downloaded and installed the main plugin, translation management and because I thought I needed it after the first time I saw the fatal error, the woocommerce plugin.

When I install String Management i get this error

Fatal error: Uncaught Error: Class 'WCCP_Settings' not found in /homepages/2/d604803240/htdocs/wp-content/plugins/woo-confirmation-page/includes/class-wccp-localization.php:67 Stack trace: #0 /homepages/2/d604803240/htdocs/wp-content/plugins/woo-confirmation-page/woo-confirmation-page.php(61): WCCP_Localization::_set_strings_to_translate() #1 /homepages/2/d604803240/htdocs/wp-includes/class-wp-hook.php(286): WCCP->init('') #2 /homepages/2/d604803240/htdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /homepages/2/d604803240/htdocs/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /homepages/2/d604803240/htdocs/wp-settings.php(327): do_action('plugins_loaded') #5 /homepages/2/d604803240/htdocs/wp-config.php(98): require_once('/homepages/2/d6...') #6 /homepages/2/d604803240/htdocs/wp-load.php(37): require_once('/homepages/2/d6...') #7 /homepages/2/d604803240/htdocs/wp-blog-header.php(13): require_once('/homepages/2/d6...') #8 /homepages/2/d604803240/htdocs/index.php(17): require('/homep in /homepages/2/d604803240/htdocs/wp-content/plugins/woo-confirmation-page/includes/class-wccp-localization.php on line 67

As a result, I cannot add the string management plugin, and so I cannot easily translate my pages which use the WPBakery / Uncode Visual Composer.

Thanks for any help you can offer!
kane

October 11, 2018 at 2:17 pm #2808647

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.
- If the issue persists, please deactivate all plugins including WPML and see this resolve the issue or not?

Thank you

October 12, 2018 at 1:15 am #2810113

kaneC

Thanks, Norman. It was another plugin causing incompatibility. Thanks!