This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Bruno 6 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
March 28, 2019 at 5:12 pm #3484237

pak-hungP

Fatal error: Uncaught Error: Call to undefined function icl_get_string_id() in /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php:136 Stack trace: #0 /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php(119): WCML_Endpoints->register_endpoint_string('order-pay', 'order-pay') #1 /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php(89): WCML_Endpoints->get_endpoint_translation('order-pay', 'order-pay', NULL) #2 /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php(22): WCML_Endpoints->register_endpoints_translations() #3 /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/classes/class-woocommerce-wpml.php(222): WCML_Endpoints->__construct(Object(woocommerce_wpml)) #4 /jet/app/www/default/wp-includes/class-wp-hook.php(286): woocommerce_wpml->init('') #5 /jet/app/www/default/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #6 / in /jet/app/www/default/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-endpoints.php on line 136

March 28, 2019 at 5:16 pm #3484249

pak-hungP

it's urgent. Could you help me as soon as possible. thanks

March 29, 2019 at 12:37 pm #3491299

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This seems like the problem happens because either String Translation is not enabled or has not been updated. Can you tweak the backend of your site? If not, please follow the steps below:

- Open your FTP client
- Go to the wp-content/plugins/
- Rename the "woocommerce-multilingual" to "woocommerce-multilingual-bak"
- Go to the WordPress dashboard
- Click on the Plugins > Installed Plugins
- Verify that WPML String Translation is up-to-date and enabled
- Go to the your FTP client
- Go to the wp-content/plugins/
- Rename the "woocommerce-multilingual-bak" to "woocommerce-multilingual"

By following the steps above, make sure your site loads correctly.

Thank you.

The topic ‘[Closed] fatal error after update string’ is closed to new replies.