Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 22 replies, has 3 voices.

Last updated by Dražen Duvnjak 2 months, 1 week ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 11, 2022 at 11:41 am #11198601

alexT-32

I am trying to:
load admin area

Link to a page where the issue can be seen:
hidden link

I expected to see:
list of plugins

Instead, I got:
Fatal error: Allowed memory size of 2147483648 bytes exhausted (tried to allocate 262144 bytes) in /www/dev.elitamoda.com/wp-includes/plugin.php on line 121

Fatal error: Allowed memory size of 2147483648 bytes exhausted (tried to allocate 262144 bytes) in Unknown on line 0

When I disable sitepress-multilingual-cms the problem disappears

May 11, 2022 at 11:51 am #11198653

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

The "allowed memory exhausted" error is usually related to server/hosting settings so they (the hosting support) might be the only ones who can fix it.

However, there are a good amount of existing tickets related to this exact error with recommendations and solutions from our team.

I created this custom search URL below - can you please take a look at the tickets showing up and see if the solution that worked for the customers works for you, too?

Please let me know how that goes.

- hidden link

PS: Also, please make sure your server environment meets our minimum requirements as described here:
https://wpml.org/home/minimum-requirements/

Kind regards,
Mihai Apetrei

May 12, 2022 at 10:37 am #11207013

alexT-32

Tried all steps still infinite loop with 2GB memory_limit, default theme and only "WPML Multilingual CMS" enabled.

May 16, 2022 at 9:24 am #11227791

alexT-32

Hey, I am still in a need of help. Please, let me know if you need any information.

Thanks.

May 16, 2022 at 8:19 pm #11232845

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

This can be fixed by your hosting provider in minutes. Please show the error message to them and ask them to increase the memory limit as much as they can for your plan.

Please check more information about this error: hidden link

Also, have you tried to increase your WP memory limit? In the URL below, we have suggested the value '256M', but please test it with '768M', too.

https://wpml.org/home/minimum-requirements/

Please let me know how that goes.

Mihai

May 17, 2022 at 9:57 am #11236393

alexT-32

I have root access to the VPS and can change any settings. I have tried activating "WPML Multilingual CMS" as single plugin with memory_limit 14336M and I still got "Fatal error: exhausted memory" error. The memory limit is already huge. There must be some infinite loop inside the plugin, eating up all the memory.

I've checked minimum requirements too. The server has all required php modules installed.

Please, have a look at attached screenshots.

Screenshot_20220517_104923.png
Screenshot_20220517_104349.png
Screenshot 2022-05-17 at 10-34-48 Plugins ‹ Интернет-магазин Elitamoda — WordPress.png
Screenshot_20220517_103054.png
Screenshot 2022-05-17 at 10-27-18 PHP 7.4.28 - phpinfo().png
May 17, 2022 at 12:31 pm #11238079

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and thank you for the update.

1. Can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

2. Can you please create a full website backup and then share the credentials with me in the private fields that I activated below?

3. Do I have your permission to duplicate this site onto a testing environment and see if the issue is taking place there, too?

Please let me know.

Mihai

May 18, 2022 at 3:37 pm #11249019

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the confirmation.

I was able to log in successfully into the backend using the credentials that you shared.

I will keep you updated as soon as I have news.

Mihai

May 20, 2022 at 10:39 am #11264773

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Can you please let me know if anything happened to the site? I am not able to access it anymore in order to test a couple more things.

I'm attaching screenshots below.

Please let me know.

Mihai

Screenshot 2022-05-20 at 13.38.36.png
Screenshot 2022-05-20 at 13.38.30.png
May 20, 2022 at 1:32 pm #11266887

alexT-32

It’s a self signed certificate, so it’s normal that your browser shows you this warning. Just press “advanced” button and choose to ignore it.

May 20, 2022 at 5:26 pm #11268463

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and thank you for your feedback.

I am accustomed to these types of screens and I always go to the "Advanced" area to skip and continue accessing that link, but it seems that this time when I was clicking "Advanced", I was getting that text saying that I still can't access it. So on my laptop, it did not work.

When I got back to my desktop, trying from there, it worked fine, so I'm not sure why it worked on one device and why it doesn't work on my laptop. But I'm in now, thanks.

I'm leaving the ticket assigned to myself.

Mihai

May 20, 2022 at 6:44 pm #11268747

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I'm back.

Unfortunately, I was not able to reproduce the issue in our testing environments.

Activating WPML worked every time, visiting the "Plugins" page worked every time and the WPML settings pages (all of them) are working as expected.

I will also attach a couple of screenshots below.

What this tells us is that the issue is on the server-side and that would need to be dealt with the hosting/server provider.

I hope that you will find this answer helpful.

Mihai

Screenshot 2022-05-20 at 21.40.08.png
Screenshot 2022-05-20 at 21.40.46.png
Screenshot 2022-05-20 at 21.40.55.png
Screenshot 2022-05-20 at 21.39.51.png
May 23, 2022 at 8:39 am #11277083

alexT-32

Hi,

Unfortunately this is not very helpful. My server clearly satisfies minimum requirements, but the plugin still doesn't work. It would be really professionally of you to exercise your expertise and knowledge of the plugin internals and have a look at the sources to find why there is such a massive memory consumption.

Regards.

May 23, 2022 at 8:26 pm #11284087

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and welcome back.

I fully understand that my response is not resolving the issue at the core but it is helping us understand that something from the server's settings is creating this issue with WPML and that is something important to know.

Unfortunately, fixing compatibility issues between WPML and a customer's server is something that falls out of our Support Policy, that is why I recommended that you get in touch with the Server/Hosting Support Team (or try to use a different hosting company). Also, we are not allowed to access our customer's server panel, the database panel, or the domain panel.

I am not trying to be rude or not helpful, but we can't help with these types of issues.

I hope that I was able to explain myself a little better this time.

Thank you for your understanding.

Mihai

May 24, 2022 at 1:01 pm #11292985

alexT-32

Hi,

Thanks for your reply. We are considering trying different VPS. Could you please specify which OS, software/versions we need to successfully activate WPML.

Thanks.

The topic ‘[Closed] Fatal error: Allowed memory size of 2147483648 bytes exhausted’ is closed to new replies.