This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 3 voices.

Last updated by Diego Pereira 6 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
April 10, 2019 at 5:24 pm #3579387

ilkaB

I am trying to:

List my currently installed plugins in wordpress

Link to a page where the issue can be seen:

none (admin panel)

I expected to see:

a list of all my plugins

Instead, I got:

Fatal error: Call to a member function get_external_repo() on null in /wordpress/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2335

PHP Version 5.6.34

April 10, 2019 at 5:41 pm #3579709

ilkaB

I have disabled all plugins in the wordpress database and enabled them one by one.

The problem is caused from "sitepress-multilingual-cms.4.2.5".
As soon as I activate this, I cannot see my plugin list anymore.

April 10, 2019 at 7:09 pm #3580569

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello there,

Welcome to WPML support forum.

While waiting that one of my teammates takes care of your case, please try these steps:

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button

Let us know if it helps.

Kind regards,

Otto

April 10, 2019 at 7:43 pm #3580991

ilkaB

All things are updated, including the WMPL plugins.
I have downloaded all WPML plugins also from the website and uploaded it manually via FTP to the server just to make sure.

The WMPL Version overview page shows I am using the latest versions.

April 10, 2019 at 8:26 pm #3581251

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @ilkab, welcome to the WPML support Forum!

This may be related to the PHP version of your server. I checked the settings of your server through debug log and saw that some items need attention:
PHP version
Upgrade the PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

Increase WP memory
Please increase the PHP memory limit to 256mb or more. Currently this memory is set to 128mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause some issues. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego