This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Unable to access plugins.php after update from WPML

Solution: Workaround: Go to Dashboard -> Updates Press the "Check again" button Scroll to the bottom and press the "Update" button Go to the Plugins page

Update for WPML 4.2.6 solved the issue finally.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by shanyB 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 10, 2019 at 6:06 pm

shanyB

I am trying to:

Working on my site.

I expected to see:

A fatal error has suddenly appeared and blocks access to the plugins page.

April 10, 2019 at 7:03 pm #3580517

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue has been escalated to our Developer Team.

In the meantime we were able to find a solution.

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button
Go to the Plugins page

Let me know if this solved the issue.

Kind regards
Andreas

April 10, 2019 at 7:24 pm #3580817

shanyB

My issue is resolved now. Thank you!

April 10, 2019 at 7:42 pm #3580963

shanyB

Hi,

I still have error with WPML.

April 10, 2019 at 7:52 pm #3581031

shanyB

Just to give more details. The problem appeared suddenly during the WPML component update. Everything was working normalelemt before.

April 10, 2019 at 7:55 pm #3581083

shanyB

When I try the steps you propose :

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button
Go to the Plugins page

The problem seems settled, but comes back after a few minutes

On the front-end : hidden link

April 11, 2019 at 5:15 pm #3591181

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the provided information.

The error shown on your first screenshot indicate an issue between WPML and the current child theme. Could you please test if the errors disappear if you switch to the Divi theme or a default theme like TwentySeventeen?

We are very sorry about the inconvenience and I have updated our developers about the issue. Our team will investigate and provide a solution as soon as possible.

I will contact you once I received feedback.

Kind regards
Andreas

April 11, 2019 at 5:42 pm #3591505

shanyB

The problem persist even if I switch to the Divi theme.

Here the error than appear in the admin custom-post-type 'Project' (rename product) single page :

Warning: Illegal offset type in isset or empty in /www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247 Notice: wpdb::prepare est appelée de la mauvaise manière. La requête n’attendait qu’un unique substitutif/placeholder, mais un tableau de multiples substitutifs a été envoyé. Veuillez lire Débogage dans WordPress (en) pour plus d’informations. (Ce message a été ajouté à la version 4.9.0.) in /www/wp-includes/functions.php on line 4667
Erreur de la base de données WordPress : [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 9]
SELECT wpml_translations.translation_id, wpml_translations.element_id, wpml_translations.language_code, wpml_translations.source_language_code, wpml_translations.trid, wpml_translations.element_type FROM wp_g755n7r9ty_icl_translations wpml_translations JOIN wp_g755n7r9ty_posts p ON wpml_translations.element_id = p.ID AND wpml_translations.element_type = CONCAT('post_', p.post_type) JOIN wp_g755n7r9ty_icl_translations tridt ON tridt.element_type = wpml_translations.element_type AND tridt.trid = wpml_translations.trid WHERE

Warning: Illegal offset type in isset or empty in /www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 257 Warning: Illegal offset type in /www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 258 Warning: Illegal offset type in isset or empty in /www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 262

April 29, 2019 at 10:51 pm #3706867

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given. Afterwars please provide me the results of the debug.log file inside of the wp-content folder.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

April 29, 2019 at 11:03 pm #3706883

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given. Afterwars please provide me the results of the debug.log file inside of the wp-content folder.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 3, 2019 at 10:09 pm #3738189

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It has been a while and I can see this ticket is still open.

The latest update for WPML 4.2.6 should have solved the issue that you were experiencing. Did you apply the update already? If not, please go to Plugins -> Add new -> Commercial and search for updates, if necessary. Then download and activate them and let me know if the issue is solved.

Thank you!

Kind regards
Andreas

May 5, 2019 at 11:56 am #3742627

shanyB

Thank you!