Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Fatal error message on website when WPML plugin is activated. The whole site shuts down.

Solution: This issue was resolved by deactivating all plugins and turning them back on one by one.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 5 voices.

Last updated by henrikF-3 5 years, 8 months ago.

Assigned support staff: Bobby.

Author Posts
May 3, 2016 at 10:12 pm #874582

kellyS-6

I purchased your full $200 version of WPML and loaded all the files to my website in the plugins area. When I activated the main WPML file it shuts down my website and all I get on the home page is this fatal error message:

Fatal error: __clone method called on non-object in /home/content/p3pnexwpnas06_data03/92/3181492/html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2875

I will need to deactivate the plugin again once I send this support request in so my website works again. Please let me know if you need login access to my WP dashboard to troubleshoot and I can provide.

Screen Shot 2016-05-03 at 2.52.58 PM.png
May 3, 2016 at 11:56 pm #874605

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

May I kindly ask you to please verify that your site is meeting or exceeding our current min requirements

=> https://wpml.org/home/minimum-requirements/

Meanwhile, please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

May 4, 2016 at 4:47 pm #875350

kellyS-6

Yes, my website meets all of those minimum requirements.

I loaded in a different theme as you suggested and then reactivated 'WPML Multilingual CMS' and it did not have the error - the theme (Twenty Fourteen) worked fine. When I changed the theme back again it gave me the same fatal error message. I have attached a screenshot showing you the plugin that is causing the issue + my theme info. I am using Enfold by Kriesi - a very popular theme that is all up-to-date with latest version and supposedly has built in compatibility with WPML.

Screen Shot 2016-05-04 at 9.44.17 AM.png
Screen Shot 2016-05-04 at 9.36.52 AM.png
May 4, 2016 at 7:10 pm #875469

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the screenshots !

the issue seems to be with the theme causing this fatal error

please, turn on your WordPress debug.
From this page:
http://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

Also please let me know if it would be possible to provide me a copy of your theme to test on a local site and try to replicate the issue

May 4, 2016 at 8:04 pm #875506

kellyS-6

I don't see that 'wp-config.php' file in my editor. Screenshot of the config files I do have available attached. Also, is there a private area I can send you user login info. for the site so you can go in and look around yourself? I can also send you a link to the theme through that private area.

Screen Shot 2016-05-04 at 1.02.02 PM.png
May 4, 2016 at 8:23 pm #875518

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the screenshot!

In order to follow the steps i have outlined above please use your FTP instead of within WordPress.

Please do make sure you provide me with the debug information and i will be also enabling the private box reply

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

May 5, 2016 at 3:20 pm #876175

leandroB-2

As “kellyS-6”, I purchased your full $200 version of WPML and loaded all the files to my website in the plugins area. When I activated the main WPML file it shuts down my website and all I get on the home page is this fatal error message:

Fatal error: __clone method called on non-object in /htdocs/public/www/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2875

On WordPress 4.5.1, the template is “Bridge” from Themeforest, Compatible With WPML.

Please Help, please HELP!!!
leandro

May 5, 2016 at 3:22 pm #876177

leandroB-2

hidden link

May 5, 2016 at 11:30 pm #876442

kellyS-6

Hi Bobby,

Haven't heard anything from you today and wondering if you are finding a solution to this? I sent you the login and FTP info privately so you could access the website directly. Looks like I am not the only person having this problem.

Thanks,
Deb

May 6, 2016 at 1:12 am #876468

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello @leandrob-2

Please feel free to subscribe to this thread for any updates while i am debugging this issue.

I do recommend opening a new thread within the forum so we could work on your current issue for a more personalized solution and faster service

Thank you,
Bobby

May 6, 2016 at 1:17 am #876469

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Deb,

Thank you for the Access Details ,

you mentioned that you could sent me a link to the theme? that is important because i need to test the theme locally .

Also please do let me know if now you can see the error.log when using your FTP.

I have enabled the private box reply once again for you

May 7, 2016 at 6:40 am #877290

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for sharing the link for the theme !

As far as the error log sometimes it takes a bit to show please check again and let me know

Thank you,
Bobby

May 9, 2016 at 4:49 am #877816

kellyS-6

I'm sorry but I am not sure where you are wanting me to look for this error log. Can you be more specific on its location? Also, why can you not look for it seen as you now have FTP access per my earlier email to you? Thanks.

May 9, 2016 at 6:52 pm #878598

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The error log is in your main directory within the FTP, i was able to get it using your FTP details .

I am trying to replicate the issue on my local install but im currently missing the stylesheet for the theme from the zip file you provided me with, therefore i cannot install the theme.

May i kindly ask you to please try and share the theme with me again

you can sent the zip file here :

bobby.k@onthegosystems.com

Thank you,
Bobby

May 10, 2016 at 5:33 pm #879537

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

The issue should be resolved, when i used your theme on my local install i noticed that there were no errors therefore it wasnt the theme but another plugin causing this issue.

I deactivated and activated all plugins one by one and the issue has been resolved

WPML is currently active on your site please go ahead and choose your secondary language from within WPML=>Languages