This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by michaelS-200 2 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 17, 2019 at 6:17 pm #4232909

michaelS-200

Hi,
I uploaded and installen WPML.
I tried to activate and get this message:

Plugin could not be activated because it triggered a fatal error.
Warning: require(/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php): failed to open stream: No such file or directory in /mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 69 Fatal error: require(): Failed opening required '/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php' (include_path='/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/archive_tar:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/console_getopt:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/http_request2:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/mail_mime:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/mail_mime-decode:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/net_url2:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/pear-core-minimal/src:/mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/backwpup/vendor/pear/pear_exception:.:/opt/RZphp71/includes') in /mnt/web106/b2/31/53177931/htdocs/WordPress_16/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 69

So I deleted it and uploaded via file manager and it said:
Data is not JSON.

Tried to activate and get same error message.

What do you suggest? My skills are limited?

Thanks
Mike
hidden link

July 17, 2019 at 8:05 pm #4233321

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

this is happening when you are uploading the main WPML plugin correct ?

when you uploaded it through the File Manager did you use a fresh version downloaded from here https://wpml.org/downloads/ ?

if not , please download a fresh version and let me know your results

If the issue persists if possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 18, 2019 at 7:05 am #4235567

michaelS-200

sorry hidden link not ssh...

July 18, 2019 at 9:31 pm #4242451

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

I did a few tests and was able to pinpoint the theme Make by The Theme Foundry causing this fatal error with WPML

one possible workaround is to briefly deactivate the theme and switch to a default theme , then activate WPML and afterwards activate your theme Make again.

If possible please contact the theme authors as well and share this with them and let me know their response that way i can start a compatibility process for this theme

The theme Make is currently not listed as compatible with WPML but the author has worked before with us on making another one of their theme's compatible (Duet)

https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=112987&wpv-theme-category=0&wpv_post_search=&wpv_filter_submit=Search

let me know your results please

July 20, 2019 at 12:59 pm #4249873

michaelS-200

My issue is resolved now. Thank you! Great work!