This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Fatal error: Uncaught Exception: Invalid order. in /.../public_html/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php:101

Solution:

A plugin was conflicting. Disabling the third party plugins solved the issue.

This topic contains 10 replies, has 3 voices.

Last updated by jesperH-9 3 weeks, 1 day ago.

Assigned support staff: Riffaz.

Author Posts
September 20, 2019 at 6:03 pm #4614035

Mark

We are seeing the following error at the bottom of the Edit Product screen when WP_DEBUG is enabled:

Fatal error: Uncaught Exception: Invalid order. in /.../public_html/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php:101
Stack trace:
#0 /.../public_html/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(159): Abstract_WC_Order_Data_Store_CPT->read(Object(WC_Order))
#1 /.../public_html/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-order.php(111): WC_Data_Store->read(Object(WC_Order))
#2 /.../public_html/wp-content/plugins/woocommerce-multilingual/inc/currencies/class-wcml-multi-currency-orders.php(143): WC_Abstract_Order->__construct(9057)
#3 /.../public_html/wp-includes/class-wp-hook.php(288): WCML_Multi_Currency_Orders->_use_order_currency_symbol('$')
#4 /.../public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters('$', Array)
#5 /.../public_html/wp-content/plugins/woocommerce/includes/wc-core-functions.php(687): apply_filters('woocommerce_cur...', '$', 'CAD')
#6 /.../public_ht in <b>/.../public_html/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php on line 101

I've switched to default theme and deactivated the other plugins and the issue persisted. However, if I deactivate WooCommerce Multilingual the issue is gone.

September 23, 2019 at 6:13 am #4620577

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

The first WooCommerce issue makes the second WCML issue.
If you disable the WooCommerce Multilingual, are you able to edit the products or still the see the same issue?

Let me know.

Regards,
Riffaz.

September 23, 2019 at 11:32 am #4623113

Mark

Yes, if I disable WooCommerce Multilingual the issue is gone and I'm able to edit the products with no error message.

September 24, 2019 at 3:11 am #4627633

Mark

FYI- we have contacted woocommerce and they have advised this is an issue with this plugin.
Please help!

September 24, 2019 at 8:48 am #4629223

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for checking this.

I consulted with our developers as well.
They say it is something never experienced before.

So we need to check this in a fresh environment.
Please:
1. go to hidden link
2. install your theme
3. activate WooCommerce (already installed)
4. configure WPML as you have it on your site (at the last step (sitekey) just click next)
5. create only one product
6. translate it
7. make an order
8. see if you have the same issue.
9. let us know how to check the issue.

From there our developers will dig it deeper.

You may feel you do not have time to do this but typically it takes only 2 minutes to 10 minutes as everything is already pre configured.

Let us know.

Regards,

September 24, 2019 at 10:59 am #4630893

Mark

Have added the theme, activated woocommerce and setup WPML.
Created a product, but cannot get to shop to test an order

September 24, 2019 at 12:56 pm #4631735

Mark

I was able to get the theme up and running and submit an order and I do not see the error message.

Can you duplicate our site to help me troubleshoot this? The only way I can remove the error is by deactivating the Multilingual plugin.

September 24, 2019 at 12:56 pm #4631737

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for checking this up.

Here is the shop: hidden link
I placed an order: hidden link

Could you please check now that can you reproduce the original issue on the sandbox ?

Regards,

September 24, 2019 at 1:48 pm #4632173

Mark

I discovered that there was a plugin on our site that was causing the issue! Thanks for your help.

September 26, 2019 at 9:07 pm #4650379

jesperH-9

Hi Mark, I am experiencing the same problem on my site.

I hope you can help me to understand how to fix the issue. Which plugin was making a conflict in your setup (maybe I have the same or a similar plugin)? And what did you do to solve the issue?

Thanks a lot! 🙂

Best regards,
Jesper

October 1, 2019 at 3:45 pm #4673545

jesperH-9

Hi Mark,

I still have this issue, so I hope you can help me? Any info on what you did to remove the error (maybe a specific plugin?) is highly appreciated! 🙂