If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Ryan 2 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
August 20, 2019 at 6:41 pm #4426005

Ryan

I am trying to:Restore a back-up.

Link to a page where the issue can be seen: hidden link

I expected to see: A copy of hidden link

Instead, I got: Fatal error: Uncaught Error: Call to undefined method stdClass::get() in /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings-strings.php:94 Stack trace: #0 /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings-strings.php(56): WPML_LS_Settings_Strings->translate_slot_strings(Object(stdClass)) #1 /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php(250): WPML_LS_Settings_Strings->translate_all(Array) #2 /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php(378): WPML_LS_Settings->maybe_init_settings() #3 /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php(343): WPML_LS_Settings->get_setting('menus') #4 /home/nicom/aemltd.nicomitcms.com/wp in /home/nicom/aemltd.nicomitcms.com/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings-strings.php on line 94

August 20, 2019 at 9:56 pm #4426647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Before we try something else, can you see if this works:
https://wpml.org/forums/topic/server-500-error-2/#post-2802309

"I found an entry in the wp_options table with the option name "wpml_language_switcher". I deleted this row from the database and I was then able to activate the WPML plugin."

It looks like that this client had an exact same error message, so wondering if this will work in your case as well.

Please make a full backup of your site before trying this or make these changes on a staging/development site!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

let me know your results please

August 21, 2019 at 5:11 pm #4434145

Ryan

Thanks for the reply and info Bobby. I contacted my host for help looking at the database. Below is what they had to say. I'm a little unsure at this point if this is a WPML issue or a theme issue. But I'll wait to see what your reply is before doing anything more. Here is what DreamHost had to say...

"I logged into the database for aemltd.nicomitcms.com and did not find that option name "wpml_language_switcher". The database name is 'aemltd'.
To login to the database navigate to the URL below:

mysql.nicomitcms.com

user name is: nicomitcmscom

If you need to view its password navigate to the 'mysql databases'
section in your account's web panel:

hidden link;

Find the user name and click on it. On the next page click 'show' next to 'current password' to view its password.

hidden link

Once you login, click on the database name on the left: aemltd, click and click 'wp_options' to see the option name lines. I also notices another
error:

Notice: Trying to get property of non-object in /home/nicom/aemltd.nicomitcms.com/wp-content/themes/enfold/framework/php/function-set-avia-frontend.php
on line 66

I found that disabling the theme also gets rid of the 'Fatal error', so it may be related."

August 21, 2019 at 10:17 pm #4435225

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for updating me , have you been able to reach out to the theme support ?

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 22, 2019 at 8:36 pm #4442831

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the access details ,

i was able to find the 'wpml_language_switcher' field using the following SQL command

SELECT * FROM `wp_options` WHERE (CONVERT(`option_name` USING utf8mb4) = 'wpml_language_switcher' OR CONVERT(`option_value` USING utf8mb4) = 'wpml_language_switcher' OR CONVERT(`autoload` USING utf8mb4) = 'wpml_language_switcher') LIMIT 50

the value of the field was corrupted therefore i have re populated it, and it seems to be working as expected now

August 23, 2019 at 5:26 pm #4449139

Ryan

Thanks very much Bobby. That did the trick. I was able to fix the error with the theme as well by updating it. Thanks again!