This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Not able to access Plugins after WPML Update

Solution: Go to Dashboard -> Updates Press the "Check again" button Scroll to the bottom and press the "Update" button Go to the Plugins page

WPML Update 4.2.6 solves issue completely

This topic contains 11 replies, has 7 voices.

Last updated by reinerB-3 6 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 10, 2019 at 4:48 pm #3578903

Jessica

I'm getting this error on my plugins page (all plugins, not the commercial tab).

It triggers when WPML Multilingual CMS is active.

I did the last update on April 3rd I think, but did not realize this happened, because Commercial page works fine.

I tried:

- FTP: manually deleting all WPML plugins and reinstalling latest versions, starting with WPML Multilingual CMS

- Deactivating all other plugins

I 'd rather not use a backup to fix this, since I made important changes to my website since the last backup...

Everything seems to work correctly on my site, except that I can't access my plugins page anymore, at least not without FTP deactivating WPML Multilingual CMS.

April 10, 2019 at 5:15 pm #3579309

joanR-8

I have the same issue:

Fatal error: Uncaught Error: Call to a member function get_external_repo() on null in ...

And no plugins are shown on the plugins page.

April 10, 2019 at 5:16 pm #3579335

glebM

Same, seems a bug in latest update of WPML. It also throws quite a lot warning if debugger enabled

April 10, 2019 at 5:16 pm #3579337

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Please download the latest versions of WPML Multilingual CMS 4.2.5 at https://wpml.org/downloads.

Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.5 again.

Then go to Plugins -> Install -> Commercial and download the add-ons. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

Please let me know if the issue has been resolved.

Kind regards
Andreas

April 10, 2019 at 5:21 pm #3579351

Jessica

Not working

April 10, 2019 at 5:29 pm #3579417

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 10, 2019 at 5:32 pm #3579455

ivan-alexisM

Exactly the same problem here, and also a bunch of notices in admin page

Notice: Undefined index: slug in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 27

Notice: Undefined index: name in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 30

Notice: Undefined index: name in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 34

Notice: Undefined index: slug in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 35

Notice: Undefined index: description in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 36

Notice: Undefined index: changelog in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 37

Notice: Undefined index: version in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 38

Notice: Undefined index: date in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 40

Notice: Undefined index: url in wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 41

Notice: Undefined index: basename in /wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 44

April 10, 2019 at 6:12 pm #3580143

heikoT

Hi,

I have the same problem. I can not even deactivate the plugin, since the plugin page does not open, it just shows the error.

I will open a new ticket for this, to get personal support.

Cheers

April 10, 2019 at 6:39 pm #3580377

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue has been escalated to our Developer Team.

In the meantime we were able to find a solution.

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button
Go to the Plugins page

I already applied the changes on your site and you are able to install plugins again.

Kind regards
Andreas

April 10, 2019 at 6:51 pm #3580467

Jessica

Awesome! Thanks Andreas!

April 10, 2019 at 9:07 pm #3581441

reinerB-3

I have the same problem:

Fatal error: Uncaught Error: Call to a member function get_external_repo() on null in /www/htdocs/w01753d7/waschbecken-online.de/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php:2335 Stack trace: #0 /www/htdocs/w01753d7/waschbecken-online.de/wp-includes/class-wp-hook.php(286): WP_Installer->setup_plugins_page_notices('') #1 /www/htdocs/w01753d7/waschbecken-online.de/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /www/htdocs/w01753d7/waschbecken-online.de/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /www/htdocs/w01753d7/waschbecken-online.de/wp-admin/admin-header.php(276): do_action('admin_notices') #4 /www/htdocs/w01753d7/waschbecken-online.de/wp-admin/plugins.php(459): require_once('/www/htdocs/w01...') #5 {main} thrown in /www/htdocs/w01753d7/waschbecken-online.de/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2335

April 10, 2019 at 9:10 pm #3581453

reinerB-3

Solved! Thanks