This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Fatal error: Uncaught Error: Class 'WPML_Translation_Management' not found in

Solution: https://wpml.org/forums/topic/fatal-error-uncaught-error-class-wpml_translation_management-not-found-in/#post-4627891

This topic contains 6 replies, has 2 voices.

Last updated by Eduardo 3 weeks, 3 days ago.

Assigned support staff: Riffaz.

Author Posts
September 23, 2019 at 6:24 pm #4626107

Eduardo

Tell us what you are trying to do?
Back End Error page
Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

September 24, 2019 at 4:03 am #4627891

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We have an easy workaround for the bug now and the error is expected to fix in WPML 4.2.9. Actually, we have to modify the database value directly to fix the issue. This may make issues in the settings. So please try the following steps after a full site backup and make sure the issue is existing or not.

1) Add the following code in functions.php of your theme

add_action('wp', function (){
   $wpml_settings = get_option('icl_sitepress_settings');
     
   if (!empty($wpml_settings['show_untranslated_blog_posts'])) {
       unset($wpml_settings['show_untranslated_blog_posts']);
       update_option('icl_sitepress_settings', $wpml_settings);
   }
});

2) Visit the frontend of the site

3) Remove the newly added code from the functions.php file

--
Thanks!
Riffaz.

September 24, 2019 at 7:24 am #4628569

Eduardo

Hello Riffaz,

thanks for your fast reply.
I followed your instructions, but the issue still persists...to clarify, the ERROR arises in the back end only, after reloading I have normall access to the dashbord, etc.

Besides the above, another issue, this components are not complete upsated, althoug I uploaded the latest versions;

wpml-string-translation
wpml-translation-managemen

Kind regards | Eduardo

September 24, 2019 at 12:38 pm #4631567

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Do you mean, you are seeing tis issue https://wpml.org/wp-content/uploads/2019/09/4626107-Screenshot_2019_09_23_at_13.10.29.png even after you add the code as I explained?

Anyhow, we released a new version today.
Please disable your current WPML plugins.
Delete them. (deleting WPML will not delete your translations. Translations are in database)
Download fresh copies from https://wpml.org/account/downloads/
Install and activate.
This should be fixed by then.

Regards,

September 24, 2019 at 2:22 pm #4632397

Eduardo

I followed your updates instructions, the problem persits with a differen ERROR message, see screen shot pls.

September 25, 2019 at 6:20 am #4635847

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Did you update the WPML plugins successfully?
If you have the latest versions of WPML plugins you should NOT see these errors.
Let me know.

Regards,

September 25, 2019 at 1:48 pm #4639383

Eduardo

My issue is resolved now. Thank you!