This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.09 hours from now. Thank you for your understanding.

This topic contains 14 replies, has 2 voices.

Last updated by Shekhar Bhandari 9 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
January 16, 2019 at 6:44 am #3096268

sorenn-3

after translation I get this error
Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Page_Builders_Page_Built::is_page_builder_page() must be an instance of WP_Post, null given, called in .../wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/tm/class-wpml-pb-handle-post-body.php on line 33 and defined in .../wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/utilities/class-wpml-page-builders-page-built-with-built.php:16 Stack trace: #0 .../wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/tm/class-wpml-pb-handle-post-body.php(33): WPML_Page_Builders_Page_Built->is_page_builder_page(NULL) #1 .../wp-includes/class-wp-hook.php(286): WPML_PB_Handle_Post_Body->copy(false, '12', Array) #2 .../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #3 .../wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/skyaid18/p in .../wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/utilities/class-wpml-page-builders-page-built-with-built.php on line 16

January 16, 2019 at 10:16 am #3096969

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please provide me the login details so I can check this issue further? I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

January 17, 2019 at 11:39 am #3101626

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please provide a link to the page where I can see this fatal error?

Look forward to your reply.

Thanks

January 17, 2019 at 1:32 pm #3102175

sorenn-3

Hi,

go to admin, wpml, translations then you get the error

Thanks

January 18, 2019 at 3:54 am #3104743

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I went to the admin, WPML -> translations, but couldn't replicate the problem, I added a new post but couldn't see the same issue, further I also enabled the debugging on the site and the error is not showing, could you please check if the issue still exists?

Look forward to your reply.

Thanks

January 18, 2019 at 7:14 am #3104853

sorenn-3

can you try and login with these updated credentials? the error should appear

January 18, 2019 at 9:19 am #3105219

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

With the updated details too, the issue is not being reproduced, could you please test the issue on a private browser or from a different browser if possible.

Look forward to your reply.

Thanks

January 18, 2019 at 9:43 am #3105342

sorenn-3

That is very strange, I get the error from my cellphone, on 2 different networks ip, on my windows pc, on my mac on my virtual machine when I login.

All the same result as I show above.
From chrome browser, safari and ie, and my samsung browser all the same result

January 18, 2019 at 9:45 am #3105345

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Indeed it's strange, Could you please go to WPML-> Support ->Troubleshooting and click the below buttons and let me know if that helps:

+ Set Language information
+ Clear Cache in WPML
+ Fix element types collation
+ Assign translation status to duplicated content

Look forward to your reply.

Thanks

January 18, 2019 at 9:52 am #3105358

sorenn-3

I have followed the steps above still the same result

January 18, 2019 at 10:03 am #3105399

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I checked this issue on a different browser and I can see that issue now, could you please follow the below steps and let me know if this helps:
- Go to WPML -> Translation management -> Translation Jobs
- Check the "Delayed flight compensation"
- Cancel the job

Let me know if this helps.

Thanks

January 18, 2019 at 11:14 am #3105741

sorenn-3

I have cancelled that job but still same issue. As I said initially the error came after I translated gravityform

January 18, 2019 at 11:32 am #3105773

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please use the solution provided here:
https://wpml.org/forums/topic/fatal-error-while-translating-gravity-form-after-upgrading-wpml/#post-3053607

Let me know if this helps.

Thanks

January 18, 2019 at 5:49 pm #3107019

sorenn-3

yes that worked can you please delete the link to my path in this thread so its not public. /home/s....
thank you

January 21, 2019 at 6:41 am #3110715

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have removed the exact paths from the ticket.

Thanks