If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Slash_Management::parse_missing_host_from_path()

Solution: Settings the different domains worked properly.

Relevant Documentation: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by alirezaB-2 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 30, 2018 at 3:55 am #2860448

alirezaB-2

now I have another problem!!! My website doesn't come up anymore and I can see only this code (see screenshot). I have deleted the plugin and have installed again and that has occurred again.

October 30, 2018 at 3:59 am #2860460

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Which version of WPML plugin are you using? For helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions etc. You can easily send this using Debug information settings from WPML. So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Further, we recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

October 31, 2018 at 2:28 am #2864199

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I received your feedback from previous ticket https://wpml.org/forums/topic/issue-with-redirect-the-domains/#post-2860952.

To further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

November 2, 2018 at 12:38 am #2870276

alirezaB-2

There are my Domains with SSL URL:

Original domain- English hidden link
German: hidden link
France: hidden link
Spanish: hidden link
Italian: hidden link
Portuguese: hidden link

November 2, 2018 at 12:43 am #2870278

alirezaB-2

Sorry for too much message I send you one more screenshot.

November 2, 2018 at 5:16 am #2870863

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can either create a CNAME or A record, or even web alias, could you please contact your hosting provider and ask them the steps to create a web alias or properly configure CNAME, so every domain shows the same content?

Look forward to your reply.

Thanks

November 2, 2018 at 8:37 am #2871185

alirezaB-2

Hello,

I have sent you my FTP account details in our private message. and i have opened a ticket by my Hosting company. I will tell you when I could config my DNS on Hosting server.

Thanks

November 2, 2018 at 10:43 am #2871574

alirezaB-2

Hello again,
They did only one domain for the test. Now 'rugeast.pt' has been redirected to 'rugeast.com'
Thanks

November 2, 2018 at 12:10 pm #2871829

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can still see that 'rugeast.pt' & 'rugeast.com' are pointing to a different IP address, which should be the same.

Instead of redirecting, could you please create sites, that points to the same IP address and same address?

Look forward to your reply.

Thanks

November 2, 2018 at 12:26 pm #2871879

alirezaB-2

Hello,
I did right now. you can test it

November 2, 2018 at 1:08 pm #2871949

alirezaB-2

Hello
Finally, I could redirect all of them. Now they have the same IP and you can check the plugin's setting now.

many Thanks

November 2, 2018 at 1:15 pm #2871958

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Once the site is correctly configured you can define them in WPML->Langauges->Language URL format accordingly.

Could you please add the domains there and let me know if this helps?

Look forward to your reply.

Thanks

November 2, 2018 at 2:15 pm #2872092

alirezaB-2

I have added all of them(Please see screenshot) But for example, when I open rugeast.de it will be shown on the English language! and after adding the domains, the website has been very low performance.

November 2, 2018 at 2:23 pm #2872121

alirezaB-2

I have asked from the Hosting company they told me that we have to wait for 90Min. It is slow because the process of redirecting is not completed yet.

November 3, 2018 at 10:08 am #2873718

alirezaB-2

Hello,
redirecting is completed but performance is super slow and it is definitely because of WPML plugin. When I used the option "different languages in directories", the performance and speed of the website is ok, but when I activate the "different domain per language" option, I face following problems:
1- Performance and speed is super slow
2- The website in original domain (English) is responsive, but not in other languages.
3- when I choose different languages I see right URLs in address bar, but the language of website stay always in English.

I appreciate your help