This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Noman 1 year ago.

Assigned support staff: Noman.

Author Posts
September 14, 2018 at 11:07 am #2735183

joanr-6

When I try to edit a page in a specific language I get this error:
Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0
I have expanded the wordpress memory to 512mb but it is still happening
I suspect it has to do with the 3w plugin total cache. But I do not know the reason and I can not edit.
Do you have knowledge of this problem?
On the other hand, I have yet to update to the latest wpml version, is it safe to perform the automatic update on the backend if the web is in production?
a greeting

September 14, 2018 at 1:41 pm #2735611

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. This error usually appears due to Cache plugins. One solution as I found in forums is to Clear all modules cache and page cache in W3 Total Cache as this user described here:
https://wordpress.org/support/topic/unknown-cannot-use-output-buffering-in-output-buffering-display-handlers-in-unk/#post-3731203

Another ticket where this error occured due to another plugin:
https://wpml.org/forums/topic/problem-after-update-5/#post-2087876

- You can deactivate WPML and see if this error still occurs or not.

- Same way you can deactivate W3 Total Cache and see the results. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

And yes it is safe to update WPML plugin during production. Just make sure to take a full backup of database and website. Thank you

September 17, 2018 at 5:49 am #2739697

joanr-6

The problem has disappeared when deactivating 3w total cache. I have been able to edit but when I activate it again, the error appears again.
At the moment I will deactivate when I have to edit and I will continue investigating, it is possible that with some update it will be repaired. I have tried to update wpml but I get a message that my password is old and I can not update. How can I fix this problem? that does not happen to me in other url.

September 18, 2018 at 12:01 pm #2744962

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

Have you cleared all types of caches from W3 Total Cache plugin or its settings, like mentioned by a user in one of the above tickets that I shared, they have different modules that handles cache, you need to clean all. The one specifically mentioned in their forum is:
-- “ To rebuild the minify cache use the [empty cache] operation and clear the cache. “

As you can see that error is not coming from WPML but is related to W3 Total Cache, if the issue still appears after clearing cache, the best way would be to contact their support and submit a ticket:
https://wordpress.org/support/plugin/w3-total-cache

For updating WPML, yes you can try that. If you are getting a key error, you need to generate a new key from your WPML account and re-add it in your site. Please login to your WPML account >> My Sites page >> Delete old key for your site and create a new key >> then add it in your site again:
https://wpml.org/account/sites/

You can add the new key for WPML by going to:
WP Dashboard >> Plugins >> Add New >> Commercial tab >> Unregister WPML and re-add the key >> Update plugin again.

Thank you

The topic ‘[Closed] Fatal error: Unknown: Cannot use output buffering in output buffering display ha’ is closed to new replies.