Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to save a Post Field Group created by Toolset Types, but I got this error: Uncaught exception 'Exception' with message 'Could not add String with arguments: value: Role allow_empty_value: language: en...

Solution: - Backup your site - Go to WPML -> String translation - Select the domain "types (obsolete)" - Delete all the strings within the domain

Before doing it you may want to check if the strings are already translated within the "types" domain.

Also, you may export the .po file of the "types (obsolete)" domain and then import it to the "types" domain in WPML -> String Translation -> "Import / export .po"

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Otto 4 years, 10 months ago.

Assigned support staff: Otto.

Author Posts
September 5, 2016 at 2:04 pm #1061071

Kristof

I am trying to: Save a Post Field Group created by Toolset Types
I expected to see: confirmation
Instead, I got: this error

Fatal error: Uncaught exception 'Exception' with message 'Could not add String with arguments: value: Role allow_empty_value: language: en' in /home/itinerainst/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php:190 Stack trace: #0 /home/itinerainst/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php(135): WPML_Register_String_Filter->save_string('Role', false, 'en', 'plugin Types', '', 'field role name') #1 /home/itinerainst/public_html/wp-content/plugins/wpml-string-translation/inc/functions.php(265): WPML_Register_String_Filter->register_string('plugin Types', 'field role name', 'Role', false, '') #2 /home/itinerainst/public_html/wp-content/plugins/types/library/toolset/types/embedded/includes/wpml.php(186): icl_register_string('plugin Types', 'field role name', 'Role', false) #3 /home/itinerainst/public_html/wp-content/plugins/types/library/toolset/types/includes/fields.php(551): wpcf_translate_register_s in /home/itinerainst/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php on line 190

September 5, 2016 at 3:30 pm #1061218

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

❌ Before proceeding please make a full website backup! ❌

Can you, please deactivate the ICL Translation service for a moment and let me know if the issue persists?

Also, do you have any local translator active? Is it possible to you to delete it at and recreate it if needed?

Finally, can you please try if the issue persists in this scenario:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Thanks for your cooperation.

Let me know your results, please.

Kind Regards,

Otto

September 5, 2016 at 3:38 pm #1061257

Kristof

Please inform me, step by step, on how to deactivate the ICL Translation service.

September 5, 2016 at 5:52 pm #1061517

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please apologize I was not clear enough.

To deactivate ICL for testing you just need to go to:
WPML > Translation Management > Translators > Available Translation Services and deactivate ICL

After the test, you can reactivate it following the same steps.

Let me know your results, please.

Kind Regards,

Otto

September 6, 2016 at 7:35 am #1062280

Kristof

Hi Otto,
unfortunately, there is no possibility to deactivate ICL on that page, see screenshot.

Translation Management ‹ Itinera Institute — WordPress.jpeg
September 6, 2016 at 7:51 am #1062302

Kristof

I have deactivated all plugins, except WPML and Toolset Views, otherwise I could not replicate the problem, and the problem still exists, it is an issue between WPML and Toolset, but as both are your products, it should be easy to find a solution, I hope.

September 6, 2016 at 11:25 am #1062763

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you. I hope that too 🙂

To further debug the problem I'd like to replicate your site locally. For this I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

Please refer screenshot attached, remember to enable the filters and exclude this:
+ wp-uploads
+ cache
+ media
+ archive

Excluding these things will help in keeping the snapshot size minimum

:: Duplicator instructions
hidden link

. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

Once the problem is resolved I will delete the local site.

I am enabling private message for your next reply so that you can send me snapshot link and admin details of account you will create for me.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Thank you for your cooperation for debugging this issue.

Kind Regards,

Otto

September 6, 2016 at 6:30 pm #1063840

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you.

I managed to deploy your site locally.

On my local copy of your site I did the following:
-Go to Toolset > Post Fields > Edit "Articles - Advanced Fields"
-Made some edits
-Saved

And no error showed up.

Can you please provide me the steps I should follow to see the issue?

Thanks for your cooperation.

Kind Regards,

Otto

September 6, 2016 at 6:35 pm #1063844

Kristof

The error is present in the Persons - Advanced Fields, where there is a "Role" field.

September 6, 2016 at 7:39 pm #1063928

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you, I managed to reproduce the issue now.

I managed to solve it locally following this steps:
-Backup your site
-Go to WPML > String translation
-Select the domain "types (obsolete)"
-Delete all the strings within the domain

Before doing it you may want to check if the strings are already translated within the "types" domain.

Also, you may export the .po file of the "types (obsolete)" domain and the import the to the "types" domain in WPML > String Translation > "Import / export .po"

Let me know your results, please.

Kind Regards,

Otto

September 15, 2016 at 7:14 am #1080918

Kristof

thank you, that fixed it.

September 15, 2016 at 7:19 am #1080925

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

I'm glad to hear that 🙂

Kind Regards,

Otto