Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 5 voices.

Last updated by raymondv-3 5 years, 11 months ago.

Assigned support staff: Dat Hoang.

Author Posts
October 8, 2015 at 9:47 am #720336

raymondv-3

I am trying to: activate WPML plugin All Import WPML 2.0.0

URL of (my) website where problem appears: hidden link

I expected to see: help by installing the plugin

Schermafbeelding 2015-10-08 om 11.45.48.png
October 9, 2015 at 11:50 am #721483

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Apologies for the long delay!

I've checked our plugin files. We are not using a class "PMXI_Plugin" anywhere in our current+older versions. So must be a conflict between the "WP All Import" main plugin and the "WPML Add-On" plugin.

Could you ask the "WP All Import" support team which version WPML add-on should have when using (main plugin) "All Import WPML 2.0.0" ?

--
hidden link

October 9, 2015 at 4:03 pm #721788

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Change of plans - you downloaded the plugin from "WPML account > Downloads"?

If so, would you mind providing us with credentials for your website and we have a closer look at the settings? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")
Thanks in advance!

October 12, 2015 at 7:22 am #722439

maevaR

I have the same issue so I would be interested to know how you solved it! My website is still on a local environment so I can't give you access to it. But I'm using all latest versions: WP 4.3.1, WPML Multilingual CMS 3.2.7 and WPML All Import 2.0.0.
My error: Fatal error: Class 'PMXI_Plugin' not found in /Users/username/Sites/sitename/wp-content/plugins/wpml-all-import/wpml-all-import.php on line 121
Thank you !

October 12, 2015 at 8:23 am #722498

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

@maevar
Unfortunately - not solved yet :-/
If want you to we could this:
- Open an extra ticket here
- Please copy & paste what you mention here into this thread
- I will ask you then to send me a duplicate/clone of your site (and explain how to create clone easily)

October 13, 2015 at 7:25 am #723401

maevaR

Well it's a fresh WordPress install with only WPML plugins, nothing else! But it's not working. Any idea ?

October 22, 2015 at 8:54 pm #731023

Hans-Peter

I have the same problems....

October 23, 2015 at 9:59 am #731332

Dat Hoang

We are sorry for the late replies.

I'm Dat and now I'm taking care this ticket. Hope everything goes fine.

About this problem, our developers were aware of this and we will fix it in the next version.

"WPML All Import" is like a glue plugin between WPML and WP All Import: https://wordpress.org/plugins/wp-all-import/

+ If you want to import your content with WPML and WP All Import, so you should install this plugin. But before that, remember activating WPML and WP All Import.

+ If you don't want to import your content, there is no need to install it.

We have a detailed document in using this plugin: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Please let me know if there is anything else related to activating this plugin.
For the problem related to using it, I kindly ask you to open new tickets.

October 26, 2015 at 9:36 am #732399

raymondv-3

Thanks