Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Itamar 8 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
February 26, 2019 at 6:39 am

luisG-22

I am trying to translate product to another language and the feature image dont copy.
Can you help plz?

Im trying to send you WPML Debug info but it says "The debug information is not valid."

February 26, 2019 at 5:22 pm #3246471

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

About the debug info that you have trouble sending us.
Did you follow the instructions here?
http://wpml.org/faq/provide-debug-information-faster-support
Please make sure that you are copying all the content of the debug info.

For the products' featured image issue. PLease go to WPML -> Settings -> Media Translation and press the 'Start' button when the three options are selected.
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content
Does it help to see the problem?

Regards,
Itamar.

March 1, 2019 at 2:48 am #3258250

luisG-22

I dont have Media Translation installed.
I dont want to duplicate all the product images. I want to use the same image for 2 languages.

It's is necessary use that plugin?

I send you the debug now.

Thanks

March 3, 2019 at 8:29 pm #3266607

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for attaching the debug information.

You do not need to install the Media Translation add-on. By default, WPML uses duplication to make media files available in all languages. The options for translating media can be found at the bottom of the WPML -> Settings page. Please read our documentation here.
https://wpml.org/documentation/getting-started-guide/media-translation/
To use the same image in all the site's languages for you might need to run those options in WPML -> Settings -> Media Translation (scroll to the bottom). Make sure that these three options are checked and press the 'Start' button.
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content
Please see the attached screenshot settings_media_translation.jpg.

Similarly, you can also make sure that the following options are set on the editing screen of the product.
- Duplicate uploaded media from original
- Duplicate featured image from original
Please see the attached screenshot dup-media-featured-image.jpg

Please let me know if this information is helping you solve the problem.

Thanks,
Itamar.

March 3, 2019 at 8:53 pm #3266640

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi again.

In addition to the above, by looking at the debug information of your site, I can also see that WPML and its add-ons are not updated to their latest version on your site. Please update WPML and its add-ons to the latest versions to make sure that the problem is not coming from un-updated plugins.

Thanks,
Itamar.

The topic ‘[Closed] Feature image dont syncronize’ is closed to new replies.