This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 29, 2019 at 3:46 pm #3705163

praveenM

I am trying to: show the same feature image image but it does not work (for German and French version).

Link to a page where the issue can be seen: hidden link

I expected to see it work (as it does on this page): hidden link

Instead, I got no feature image on the first (Google Analytics Service related page)

April 30, 2019 at 3:48 am #3707771

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I understand you are having issues displaying featured images. Since it's hard to pinpoint what's creating the issue. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
Could you please check if those featured images are available in the secondary languages from the dashboard?

#2
I can see that you are still using an outdated version of the WPML plugins, we recently released new versions of WPML plugins with fixes and improvements. Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#3
Could you please check once if those media are translated properly? You can refer to this documentation for further info on translation media: https://wpml.org/documentation/getting-started-guide/media-translation/

Thank you for helping us to pinpoint the issue. Feel free to add any further information you may have.

Thanks

The topic ‘[Closed] Feature image not displayed in French and German version of the page (Elementor)’ is closed to new replies.