This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by matijaP 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
April 26, 2019 at 8:11 pm #3693239



i found and issue on our webiste hidden link that not all products have set featured image anymore. Primary language is english < where everything works well.

Till one week ago everything was fine but i can't remider which action or plugin update made this.

Can you help me to set those images back on second language?

Same product:
EN: hidden link
SL: hidden link


April 29, 2019 at 1:19 pm #3703655


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I am not able to reproduce the issue exactly on the site. Please check the attached images. English and Slovenian products are showing similar images.

Does it happen with all the products? Please visit WPML>>Settings>>Media Translation and make sure you have the correct settings for the new media content.

Also please make sure the following options are selected for each of the Products, on the language widget(under *Media attachments*) of the Product Edit Screen.

a) Duplicate uploaded media to translations

b) Duplicate featured image to translations

Sorry for the delay happened because of the weekend.



April 30, 2019 at 11:49 am #3710719


My issue is resolved now. Thank you!