This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Marcel 4 months, 3 weeks ago.

Assigned support staff: Marcel.

Author Posts
May 8, 2019 at 10:23 am #3765523

tobiasS-33

Hi Marcel,

Now, hidden link displays correct language, however the featured images have incorrect paths: the base url is added to the relative media path.

E.g. what should be:
wp-content/uploads//2018/02/60A8197.jpg

becomes:
wizard.wellspect.es/wp-content/uploads//2018/02/60A8197.jpg

Same thing if I go to the Media Library. Any idea why that is?

Still awaiting answer from the hosting company, will let you know.

May 8, 2019 at 10:24 am #3765533

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Tobias,

I split now the ticket to have the issues separately to handle.
I can see the 404 error in the JS Console.

I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen

Best
Marcel

May 15, 2019 at 12:58 pm #3816645

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Tobias,

thanks, I see it. Could you please install our Media Translation Add-on?
You can download it here: https://wpml.org/de/account/downloads/ or install it over Plugins -> Add New -> over the Tab "Commercial".

Doc: https://wpml.org/documentation/getting-started-guide/media-translation/

Please let me know

Best Marcel

May 15, 2019 at 2:07 pm #3817513

tobiasS-33

Hi Marcel,
Sure, Media Translation plugin installed. Still the wrong paths in Media Library though.

May 17, 2019 at 9:57 am #3832915

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Tobias,

Thanks for the site access.

I will try to reproduce this on a local multi-domain environment. Please give me some time to setup the installation. I will inform you once I found a solution to your problem.

Best Marcel

May 17, 2019 at 10:17 am #3833291

tobiasS-33

Thank you Marcel!

May 22, 2019 at 10:08 am #3864115

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Tobias,

Thanks for your patience. I was not able to reproduce your problem on a clean, local Multi-Domain Environment.

On my test with the newest WPML versions, I uploaded an image on the English domain and opened the Media Library in German (Over the Top Bar language switcher). The image remains the same. The domain inside the Media correctly changed to .de / German.

Please ask your hosting company to look at this issue as well, as it could be related to the server settings (second ticket). Please note that our doc for the Multi-Domain environment setup was related to Apache/Linux. You are using Microsoft IIS on Azure, so the hosting company need to make sure they changed the DNS and HTTP Server correctly.

Please let me know once you have an answer from them.

Best Marcel