This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 3 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
September 29, 2018 at 5:21 pm #2775743

dariab

Hi, I've installed and translated correctly the content of my site in 3 languages but I have issues with the 4 featured posts shown on the main page.
They always show the text in spanish in the homepage, but once you click and visualize the full post is translated correctly: hidden link

Can you please help?

October 1, 2018 at 8:52 pm #2779478

Ricardo Alday

Hi,

Thanks for contacting WPML support. I assume that the query used by the theme to get the Feature posts is not getting the correct translation for the elements except for the link.

Can you upload a copy of the theme to Dropbox or Google Drive and paste the link in your next reply so I can test it out?

Thanks,
Ricardo

October 3, 2018 at 6:41 am #2783555

dariab

Hi, the theme is downloadable online: https://wordpress.org/themes/juliet/
Here is the zip file on my google drive just in case: hidden link

Thanks a lot!

October 3, 2018 at 7:35 pm #2785584

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Ricardo is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

It is important for me to mention that the Juliet theme by LyraThemes is not officially compatible with WPML. You can see the list of our compatible themes here.
https://wpml.org/documentation/theme-compatibility/
Not being on this list does not mean that it is not compatible it just means we do not know yet if it is.

To check this issue, I've installed the Juliet theme on my test site, and I think that I have a solution for you. The Featured Post option is a theme option. And it can be found in the admin screens section. Please read more about it here. https://wpml.org/documentation/getting-started-guide/translating-theme-options/
Here is what you need to do.
1. Go to WPML -> Strings Translation -> Translate texts in admin screens »
2. Search for theme_mods_juliet and expend it.
3. You will see four fields with the name of juliet_frontpage_featured_posts_post_1(2,3,4).
Please see the attached screenshot jul-fea-post.jpg
4. Select the fields.
5. Press the 'Apply' button.
6. Go to the Strings Translation section, and you will be able to see these field available for translation under the admin_texts_theme_mods_juliet domain.
Please see the attached screenshot jul-in-st.jpg
7. Insert the ID of the translated English and Italian posts for each translation, check the complete checkbox and save.
Now you should be able to see the correct language for the featured posts.

Is it working for you?

Regards,
Itamar.

7.

The topic ‘[Closed] Featured posts are not translated’ is closed to new replies.