Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Laura 2 years, 2 months ago.

Assigned support staff: Laura.

Author Posts
July 1, 2018 at 11:57 pm

tonyD-4

I am trying to: Update the product image in an English product and have it update on the Chinese version as well.

I have tried deactivating all non WMPL and Woocommerce plugins and tried using 2015 theme but that issue remains. I've also updated all plugins to the beta version.

Link to a page where the issue can be seen:
New images appearing here - hidden link
Chinese version shows the old images - hidden link

I expected to see:
The new product images showing on the Chinese translation products

Instead, I got:
The old images remained.

July 4, 2018 at 2:52 am #2460018

tonyD-4

Would be good to get someone looking into this, its been 2 days already.

July 4, 2018 at 10:33 am #2462122

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the stable version should have a fix for this. We also released a new version of WCML.
Please be sure to upgrade WooCommerce too.

If this still won't work, try cleaning the WPML cache in:
WPML -> Support -> "troubleshooting" link -> "clear WPML cache" button

Moreover, the WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Also, the minimum version of MySQL required is 5.6, and you have 5.5. It could be useful to upgrade.

Let me know if this helps you or if you need further assistance.

July 4, 2018 at 11:30 pm #2465307

tonyD-4

Hi Laura,

Thanks for the reply!

The issue is still there even after doing the following.
1. Updated all plugin to the latest version
2. Clearing WMP cache
3. Increasing WP memory limit to 256m
4. You said the site needs to be at MySQL 5.6 but the server is actually running MariaDB 10.2 which is equivalent to MySQL 5.7, its interesting that WMPL debug info doesnt show the right DB system, but if you check out the health check status under Dashboard > Health Check it does confirm its MariaDB 10.2.
5. Re-saved the product images.

Whats weird is when I add the same image to the product gallery it shows correctly on the translation. You can see on this link hidden link

The new image is set at the product image and product gallery but only the gallery image shows the new one on the translated product. The old image is still showing as the product image.

July 5, 2018 at 11:09 am #2466952

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I logged into your site to give a better look and I saw WooCommerce request to update the database. Could you do that and see what happens?

July 8, 2018 at 11:29 pm #2474568

tonyD-4

Hi,

The WC database was updated but the issue is still there. Its a dev site so you can feel free to do that type of thing. If the dev site gets completely messed up its fine.

July 9, 2018 at 1:43 pm #2476507

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I found that other users had this issue too, so it has been escalated. I also found

In the meantime, I found a workaround. It's not the best solution possible, but I hope it helps:

Go to WooCommerce > Woocommerce Multilingual > Settings
Select Native WooCommerce product editing screen on the Product Translation Interface section and save
Go to the edit screen of the product
Change the language to Chinese using the language switcher at the top admin bar
Remove the featured image and upload the new one
Save

July 9, 2018 at 9:52 pm #2477903

tonyD-4

What type of time frame could I expect for the fix to be released? Not looking for exacts but are we talking a week, a month, 6 months, a millennium?

July 10, 2018 at 7:09 am #2478492

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I can't give you a timeframe, but usually, core bugs like this are resolved more quickly than compatibility issues. It also depends on how many people are affected by the bug.
If our developers can find a fix, it will be probably included in the next version of WPML. But we could also offer a workaround first.

July 12, 2018 at 1:47 pm #2489733

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

our developers suggest using the function to Duplicate the media and feature image, and re-saving the product in the original language.

Could you try and see if this fixes the issue?