This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: In Woocommerce, when I set a product to be a featured product from the overview page it doesn't sync that status to the translated products. Solution: The featured product status won't synchronize when it is set from the overview page. You need to set it on the product page.

This topic contains 12 replies, has 5 voices.

Last updated by thierryL-10 3 years, 8 months ago.

Assigned support staff: Vincenzo.

Author Posts
September 30, 2015 at 7:17 am #715033

alecS-2

In Woocommerce when I set a product to be a featured product on my website then it only does so for one language. it doesnt automatically make the same product that is in a different language also a featured product.

So the problem is every time I select new products to be featured products i now need to first do it in Dutch language and after that do it in English language. Instead i would like it to sync featured products. So if i set a featured product in Dutch it automatically also sets it to featured in English.

Hope you can help me out.

Thanks in advance!

Alec

September 30, 2015 at 5:45 pm #715607

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello and thank you for contacting WPML support!
I will take care of your ticket.

I just tested this in my local environment and it works exactly as you wish.

As soon as I set or remove the featured flag from the original language product, the translated product is updated accordingly.

Please check this:

- Go to the edit page of a product.
- Scroll all the way down to the 'Multilingual content setup' section
- Check that the '_featured' custom field is set to 'copy'

❌ Please make a full site backup before proceeding! ❌

Your WPML plugin and add-ons are not updated.
Please check this post on our blog. You will find a video and instructions for a manual update.
- https://wpml.org/2015/06/wpml-3-2-released/

September 30, 2015 at 6:52 pm #715654

alecS-2

Hi Vincenzo,

Thanks for your reply!

I've just updated the wpml plugin and addons to the latest version. I also checked if the '_featured' is set to 'copy' within my productpages, and they are on all productpages.

Unfortunately it still doesn't sync the featured product between Dutch and English...

I've also tried to set the featured product first in English to see if it then also sets the dutch product to featured, but unfortunately it also doesn't.

Any other ideas what the issue might be?

Thanks for helping out. Really appriciate it!

Alec

October 1, 2015 at 9:15 am #715933

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Attached you will find a screenshot of the place where I set the featured product.

If it is different, can you please share a screenshot of the place where you set the featured product?

- Please check if featured_item is set to sync?

- Can you please try to temporarily set a default theme (eg. Twenty fifteen) and disabling all plugins but WPML, its add-ons, WooCommerce and WooCommerce Multilingual?

Thank you

October 1, 2015 at 10:29 am #715978

alecS-2

Hi Vincenzo,

Thanks again for the reply.

here is were I set the product to be featured in woocommerce:
hidden link

I dont have the option to set the product to featured within the productpage itself, only on the overview page like in the screenshot.

About 'featured_item' set to sync, i can't find this, where can i set this? On the productpage i only see '_featured' in the wpml tab.

I changed the theme to twenty fifteen and disabled all plugins exept woocommerce an wpml + addons.
and it still doesnt sync...:(

October 1, 2015 at 1:39 pm #716128

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Do you have the Edit link showed in the screenshot?

October 1, 2015 at 1:59 pm #716142

alecS-2

Hi Vincenzo,

Yes i do! i didn't know about that.

If i set a product to featured this way it indeed does sync it for both languages, which is great. Although it works a lot easier and faster just selecting the star in the overview page.

Do you understand/know why it wont sync if i do it using the star icon?

Thanks again for helping out!

Alec

October 1, 2015 at 2:40 pm #716180

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm glad that it worked for you.

As you said, the featured product won't sync when set from the overview page.

If you wish I can send a feature request to our developers.

Please do not hesitate to open a new thread if other issues or problems arise

October 1, 2015 at 3:30 pm #716222

alecS-2

Hi Vincenzo,

Thanks, and yes if you would like to send a feature request to the developers that would be great.

Thanks for all the help!

Alec

January 28, 2016 at 12:08 pm #798714

martaL-2

I have the same problem!

January 28, 2016 at 12:54 pm #798778

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

@martal-2
In this ticket, I posted a workaround to solve the problem.

If the problem is not solved for you, please open a new ticket.

If you wish I can add your vote to this feature request in our list.

July 6, 2017 at 3:03 pm #1313700

philippeP-10

Add my vote !!!
I don't understand why is so heavy to sync all langs to feature a product 🙁
Should be by default ...

September 24, 2019 at 2:59 pm #4632631

thierryL-10

Do we still need to use the workaround?
Because we still have a syncing problem on the French listing.

The star does not work and there is a specific JS code to stop us from doing this.