This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Featured products only shown in 1 language when added with Elementor Pro widget.

Solution:
- Add an Elementor Text Editor widget.
- Add a shortcode directly:

[products limit="4" columns="2" visibility="featured" ]

This topic contains 18 replies, has 2 voices.

Last updated by Andrés 2 months, 3 weeks ago.

Assigned support staff: Andrés.

Author Posts
July 21, 2019 at 11:28 am

gilbertW-2

Hi Andres!

Finalizing my starting page, fell on this unexpected issue. Quite a lot of other people seem to have had the same issue. Tried a few solutions but without success. So I granted you access to the staging site to help you pinpoint the issue. If needed, I created a duplicator package. You can access it from the backend. Thanks in advance for you help!

I am trying to: Add a featured product section on homepage. The featured products are shown in German, but not in English and French

I expected to see: Featured products in all languages

Instead, I got: Featured products only in German

Link to a page where the issue can be seen: hidden link and hidden link or hidden link

July 22, 2019 at 5:29 am #4254053

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Gilbert!

I've been checking your site and I can replicate the issue. However, I see that you have translated your German homepage directly with Elementor editor, while for your french translation you used WPML Editor.

I've been checking how you have added your feature products, but I can't find if you use a shortcode or which mechanism you have used. Could you please indicate me step by step how you do it? I'm wondering if your shortcode has only been added in your german page and I would like to check that.

Best regards,
Andrés

July 22, 2019 at 7:09 pm #4260943

gilbertW-2

Hi Andrés!
Thanks for looking into this.
The initial page was in german, then I translated it in english and french using wpml.
Later, I did the modifications of the german, french and english pages with elementor directly.
Kind Regards,
Gilbert

July 23, 2019 at 5:09 am #4262647

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you Gilbert. However I can't find how you have added the shortcode or how you displayed your feature products, when I try to modify the block with Elementor, it is empty.

Could you please provide me a detail way how to do it or could you try to repeat the same procedure you did with your German page for your translations?

Thank you for your help.

July 23, 2019 at 7:25 pm #4268745

gilbertW-2

Hi Andrés

Thanks for your feedback.

Did you try modifying this on my site or remotely on your site? If not on my site, maybe you haven't got the Elementor Pro license. You can try on my site (I've got a backup offline).

Anyway, that's how I proceeded:

For the french version
Pages -> All Pages -> Page d'acceuil -> Edit with Elementor -> Widget "Produits" (under title "Sélection de produits de notre marché") -> Press on the pencil (see screenshot attached)

For the german version
Pages -> All Pages -> Startseite -> Edit with Elementor -> Widget "Produkte" (under title "Ausgewählte Produckte aus unserem Online-Grossmarkt") -> Press on the pencil top right (see screenshot attached)

For the english version
Pages -> Al Pages -> Home -> Edit with Elementor -> Widget "Products" (under title Featured products from our marketplace) - Press on the pencil

Instead of using the Product Widgets, I also tried with the Shortcode Widget and enter the shortcode according Woocommerce shortcode (products with visibility featured if I remember right). Didn't show the featured products either.

My guess is that the shortcode or widget picks up the German products, and don't display them in French or English, but I can't verify this. Could be something else.

July 24, 2019 at 7:54 am #4271209

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Gilbert,

Thank you for your help!

I have created a new feature product and page, then I added a WooCommerce widget, the idea was to check if the problem was related to your homepage:
hidden link

Here, everything works fine in German and French, however the English page still does not work for the feature products but it always work for the most recent products option.

1. Could you please update your Elementor and Elementor Pro?

2. If after upgrading, the problem persists, I have created a test website with a clean WordPress install. You can access it through this link:
hidden link

Please upload your plugin Elementor Pro to this test install and setup it the same way as in your website. In this way we can check if this is a compatibility issue with the WooCommerce products widget.


Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

Regards

July 25, 2019 at 10:15 am #4281693

gilbertW-2

Hi Andres

I updated Elementor on staging. The issues persists. From my point of view, the test page you set up (hidden link) doesn't work. The featured product are not the same in German, French and English.

I'll set the case in the sandbox later, when I got better connectivity. Till then, could you please check your test page on staging to see why the featured products are not the same?

Cheers,
Gilbert

July 25, 2019 at 1:07 pm #4283385

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thanks for the heads up, Gilbert. But as there may be a consistent issue with this feature, it is recommended to wait and check how it is working in our Sandbox site.

I'll wait for your results.

Regards

July 28, 2019 at 12:11 pm #4295467

gilbertW-2

Hi Andrés

I set up a case in the sandbox with the woocommerce and elementor pro "product" widgets. It works correctly there for both.

On my site, it still doesn't work, although I have the same settings. I tried disabling and enabling the other plugins. It doesn't change anything. Strange enough, for all other queries (ex: latest products, etc), it works fine...

Any idea on what it could be? If not, could you escalate this?

Thanks for your help!

Gilbert

PS: Your test page also only works in german (in french, you showed "all products" and not only "featured", so that was why you did see something. I corrected this, and now, you only see the featured products in German:/).

July 29, 2019 at 9:10 am
July 29, 2019 at 9:11 am #4298065

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Gilbert,

To troubleshoot this issue without affecting your site I created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

I just sent you a private email with the instructions for the migration.

Regards

July 29, 2019 at 12:18 pm #4299529

gilbertW-2

Hi Andrés

I migrated the site. They were some errors during migration:( I got this email:

"Oh no! It seems a problem has occurred while migrating your site to Cloudways. We apologize for any inconvenience this may have caused.

Kindly contact us as soon as possible via live chat for a satisfactory resolution of the problem.

Sincerely,
The Cloudways Team"

Don't know if you can use this. As I'm not a registered cloudways customer, didn't get support.

Kind Regards,
Gilbert

PS: I tried migrating twice, with the same result.
PS2: You can always pick up the duplicator files on staging, or use staging for debugging. I reserved this site for you.

July 29, 2019 at 4:18 pm #4301829

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you for your help, Gilbert, however we have to isolate any issue coming from your server. Although this situation probably has been caused for changing your site's default language.

Could you try to migrate your site again after deactivating all the unnecessary plugins needed for reproducing this issue?

Regards

July 29, 2019 at 10:36 pm #4303779

gilbertW-2

OK. It's migrated. I think Duplicator was creating the problems.

July 30, 2019 at 6:14 am