Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Raja Mohammed 1 year, 8 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 13, 2019 at 5:51 am

tomasD-10

Hello,
I am not able to find the source of problem, but sometime - a few times a day product on shop page hidden link just dissappear and only in default (English) language. If I resave Permalinks, everything is OK again.

Do you have experience with this problem?

May 13, 2019 at 10:42 am #3797099

tomasD-10

It happened again, you can see in the attachment.

May 13, 2019 at 12:09 pm #3797865

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

May 13, 2019 at 12:40 pm #3798233

tomasD-10

Hello Raja,
I enabled debug mode, but after the problem happened again, debug.log file was not created. I tried to solve this problem another way than resaving permalinks and if I deleted cached page, products started to display. This problem started after I migrated the website to traffic. I am able to enter concrete product page and if I switch the language to the second language (Czech) , products in Czech are displayed. The problem is only in default language.

May 13, 2019 at 12:51 pm #3798371

tomasD-10

I found many tickets with the same problem, but not a single ticket was solved succesfully.

https://wpml.org/forums/topic/woocommerce-shop-page-empty-3/

May 13, 2019 at 12:55 pm #3798397

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This seems like an issue already escalated to our developers, I am adding your ticket there. However when the issue happens again, please let me know and check if there is anything in the debug log and send the details.

Kind regards
Raja

May 13, 2019 at 1:28 pm #3798731

tomasD-10

Ok, thank you for the information. Can you estimate when the problem will be solved? It is a very bad error when a customer is unable to do the order.

May 14, 2019 at 5:25 am #3803679

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,
We are gathering more information about the issue at the moment as this is not happening all the time. I'm afraid I don't have any definite deadline as of now, I will keep you posted with the happening. I would request your patience while the higher level of supporters deal with it.

Kind regards
Raja

May 14, 2019 at 6:41 am #3803983

tomasD-10

Hello,
thank you for the information. I found the temporary solution, probably. I hope it will works then you will fix it. You can check it and maybe give advice to another people with same problem. The problem is always fixed with reflushing permalinks, so I added this code to my functions.php:

// Flush permalinks every hour
add_action('my_hourly_event', 'do_this_hourly');

function my_activation() {
if ( !wp_next_scheduled( 'my_hourly_event' ) ) {
wp_schedule_event(time(), 'hourly', 'my_hourly_event');
}
}

add_action('wp', 'my_activation');

function do_this_hourly() {
global $wp_rewrite;
$wp_rewrite->flush_rules();
}

BTW. Before I added this code, the problem has shown about 3 times. Any time debug.log was created. But I figured out that the problem shows after changes in products, posts, pages etc. are made, but it is only my suggestion.

May 14, 2019 at 11:23 am #3806275

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the heads up, I have observed the same as you did, I will convey this to the developers now I have missed this earlier.

Regards
Raja

May 24, 2019 at 12:25 pm #3884659

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please provide us with a fresh duplicator copy of your site, We are unbale to reproduce the issue in one of our clients backup. I have enabled the private fields.

I have enabled the private fields to securely share the details

Kind regards
Raja

May 25, 2019 at 4:49 pm #3889689

tomasD-10

Hello Raja,
of course I can provide you the copy, but I can not see private fields in this reply.

After I add the code I have mentioned below, the problem does not appear.

Best regards,
Tomáš

May 27, 2019 at 4:20 am #3893437

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI Tomáš,

Sorry I missed that, I have enabled the fields again, Debugging your site copy will give us some insight into your issue so its good to have a look at what's going wrong

Kind regards
Raja