This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 8 months ago.

Assigned support staff: Bruno Kos.

Author Posts
February 20, 2019 at 8:22 am #3220216

Ingrid van Vliet

We never had any problems with duplicating a page with ACF on it. Normally we fill the english page with content, duplicate it to Dutch and then adjust te content.

I don't know if it had anything to do with updating to wordpress 5.0, but now when we are duplicating an english page, the dutch fields are all empty.
All the custom fields are standard set to "don't translate", when we set them to "copy" the duplicating works fine. We have many many many "flexible content/repeater" field (more then 2000 records), it is impossible to set them to "copy" all by hand.

I have 2 questions:
- Why was duplicating never a problem, and now it is not copying the custom fields? Because we never set any custom fields to "copy" before.
- Is there a way to set all custom fields to "copy", so i don't have to do it manually.

Greetings,

Ingrid

February 20, 2019 at 3:56 pm #3222766

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Ingrid,

Thank you for contacting WPML support!

I believe that what you're asking is the same thing as here:
https://wpml.org/forums/topic/issues-with-acf-translation-jobs/#post-3151340
https://wpml.org/forums/topic/issues-with-acf-translation-jobs/page/2/

Would you mind checking that thread and my discussion with the client and let me know if that the same thing?

Regards,
Bruno Kos

The topic ‘[Closed] Fields are empty after duplicating a page with advanced custom fields (ACF)’ is closed to new replies.