This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bigul 4 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
May 30, 2019 at 4:37 pm

naomiT-2

I have these problems:
The Homepage has many search fields (it’s a real estate website). Primary language is English, I am setting the second language (Italian) with WPML.
1)On the English homepage there are 11 search fields, on the Italian home it’s showing only 4. Why?
2)I translated the strings in Italian for the search name fields, but they are still in English.
3)If I click on the Search button on the Italian home it brings to the Search Results page in English, and this page doesn’t have a switcher to Italian. I have to go in another English page from the menu to be able to find again the switcher to Italian. I really can’t understand this behaviour.

May 30, 2019 at 6:27 pm
May 31, 2019 at 8:33 pm #3933127

naomiT-2

If you think it may be a compatibility issue I need to considerate to ask the refund for the plugin.
I can't upload all the plugins on your test site, it would take too much time.

June 1, 2019 at 8:27 am #3934587

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I would like to debug it further. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 4, 2019 at 8:05 am #3949011

naomiT-2

Thanks,
Please duplicate my site if this can help you understand and solve the issue.

Vilma

June 4, 2019 at 6:34 pm #3954523

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Vilma,

Thank you for your permission. I made a Duplicator copy of the site. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

June 6, 2019 at 10:08 am #3968015

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Vilma,

For your kind updates, it is happening because of a miss configuration in String Translation. It works on my local copy after the following steps. Please try it after a full site backup and let me know your feedback.

1) Visit WPML>>String Translation
2) Choose *admin_texts_theme_search_fields* string domain from *Select strings within domain* field
3) Select the strings of *admin_texts_theme_search_fields* string domain
4) Delete the strings
5) Unhide Italian language
6) Visit the Homepage in Italian

Please check the attached images for more details.

--
Thanks!

Bigul

June 6, 2019 at 5:12 pm #3971163
naomiT-2

Thank you Bigul,
Following your directions, I was able to show all the search field on the Italian Homepage.

Now I try to make a search (the Search button should translate in Italian - I checked in the strings, it looks translated but it's not), I Click on Search and it goes on the English search result page.
Maybe because of the button still in English?

My problems are with the strings, I don't know if I have to delete some of them like you did to solve the problem.

June 7, 2019 at 4:12 pm #3977591

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Vilma,

Thank you for the feedback. I have opened a new ticket for the other issues. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

I will get back to you soon on the new tickets. Please wait. Thank you for your understanding.

--
Thanks!

Bigul