Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When I duplicate a page from it's original language selecting "copy content from original language" I expect at least to see in the field of the copied page the content from the original language or to see the content in the phrase "Field's value in original language:" however in both places the content is empty (In the original language the fields are obviously fill in).

Solution: Are these custom fields created using the Advanced Custom Fields plugin? If so, please take a look at this documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Please also try the following: - Go to the edit screen of the page (original language) - Scroll down to "Multilingual Content Setup" - Set the fields as "copy-once" and click on apply - Do a small modification on the page and save - Check if the issue persist

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by alfredoL-3 1 year, 11 months ago.

Assigned support staff: Diego Pereira.

Author Posts
March 10, 2019 at 12:18 am

alfredoL-3

Hi there,

When I duplicate a page from it's original language selecting "copy content from original language" I expect at least to see in the field of the copied page the content from the original language or to see the content in the phrase "Field's value in original language:" however in both places the content is empty

(In the original language the fields are obviously fill in)

This happens then I don't use the WPML translation editor. It would be great to solve this problem using the WPML editor, however when I try this the custom fields don't appear in the editor.

I am working with the "Home page"

Thanks in advanced.

March 11, 2019 at 2:31 pm #3313669

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @alfredol-3, welcome to the WPML support Forum!

Are these custom fields created using the Advanced Custom Fields plugin? If so, please take a look at this documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Please also try the following:
- Go to the edit screen of the page (original language)
- Scroll down to "Multilingual Content Setup"
- Set the fields as "copy-once" and click on apply
- Do a small modification on the page and save
- Check if the issue persist

Please let me know if it worked for you.

All the best,
Diego

March 12, 2019 at 8:47 am #3319515

alfredoL-3

Hello Diego,

Indeed that worked just fine. Is there a method in which I can apply "copy-once" to all the fields?

March 13, 2019 at 12:02 pm #3332745

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

You cna go to WPML > Settings > Custom Fields Translation. All custom fields of the website will be listed there, so you can update them. It will affect all pages of your website.

If you need more help just let me know.

Kind regards,
Diego

March 13, 2019 at 5:45 pm #3336891

alfredoL-3

My issue is resolved now. Thank you!