This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by martinM-27 2 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
August 4, 2019 at 4:29 am #4335617

martinM-27

I am trying to:

Synchronise all URL paths

Link to a page where the issue can be seen:

See the attached screenshots

I expected to see:

All file paths showing the correct domain in the URL path

Instead, I got:

The domain in the URL paths in the English ('Original') section of the page, when editing the Chinese version, has not updated from the development domain even though it has updated correctly when editing the English version.

More details:

When I moved the site to the live domain I updated the URL paths site-wide to replace the development domain with the live domain. This happened correctly in all instances site-wide, including in stylesheet and other theme files.

But it did not happen in the translated pages. I have had to manually update the domain in the URL paths on all Chinese language pages to ensure the site operates correctly.

In the first screenshot below (Translations-correct-file-path.jpg) you can see the edit screen in the English version of the page, after the site was moved to the live domain from the development domain. The domain in the URL paths has been correctly updated to read hidden link

In the second screenshot below (Translations-wrong-file-path.jpg) you can see the edit screen in the Chinese version of the same page. In the left-hand section showing the English ('Original') text the URL paths still contain the development domain. I have had to manually edit the URL paths in the Chinese section on all translated pages to show the correct domain (rubytuesday.com.hk).

Since I have edited the file paths on all the Chinese version pages this request is not urgent, however I would like to know how to correct the domain in the URLs in the 'Original' section of translated pages.

If, at some point in the future, I run the scan to ensure URLs are updated to point to the translated version of each page, the Chinese URLs will be *incorrectly* updated to include the development domain.

Great if you could tell me how to correct the domain in the URL paths in the 'Original' section of Chinese editing pages.

Many thanks,

Martin.

August 5, 2019 at 2:26 pm #4341307

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

404 errors that may occur after making changes to permalinks or URL site sctructures can be solved by simply saving the permalinks at Settings -> Permalinks.

Did you save the permalinks after migrating the site and the URL was still wrong on the translated pages?

Kind regards
Andreas

August 5, 2019 at 10:10 pm #4343155

martinM-27

Hi Andreas,

Yes, I saved Permalinks after migrating the site and, just for good measure, I've just saved them again.

The problem still exists.

Cheers,

Martin.

August 6, 2019 at 12:34 am #4343281

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 7, 2019 at 2:25 pm #4355941

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I have just send you a private message with instructions for migrating your live site to our test server.

Please proceed and let me know if you experienced the same issue.

Kind regards
Andreas

August 7, 2019 at 11:05 pm #4358561

martinM-27

Hi Andreas,

Many thanks - I have completed the migration of the live site to your Cloudways location.

Cheers,

Martin.

August 8, 2019 at 11:53 pm #4366249

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for migrating the site.

I am consulting our second tier support about the issue and I will get back to zou once I received feedback.

Kind regards
Andreas

August 9, 2019 at 11:07 pm #4373107

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far you can see on the screenshots the migration worked fine and the link URLs have been replaced on the page eidotr and on the translation editor. The chinese translations already are showing the new URLs for hidden link

For now, I would advise you to migrate the site back from our Cloudways Server to your site. Usually, this should solve the issue. Only make sure to take a backup of your current site and database first.

Would this be a acceptable workaround for you? If so, see private message more down on this ticket.

Kind regards
Andreas

August 11, 2019 at 12:07 am #4376027

martinM-27

My issue is resolved now. Thank you!