This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Dennis 3 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
June 13, 2019 at 5:24 pm #4015857

johannesG-8

We are using filter products by attribute widget of wooCommerce. It's a default plugin of wooCommerce. When we change the language the widget disappear from page. I figured out and read all the FAQ but didn't find the appropriate solution. Please guide us how we can resolve it

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: the blank sidebar. we would like to same widget with every language. But unfortunately currently all the widget disappear on language changing.

Thank you

June 13, 2019 at 5:28 pm #4015875

johannesG-8

We are using filter products by attribute widget of wooCommerce. It's a default plugin of wooCommerce. When we change the language the widget disappear from page. I figured out and read all the FAQ but didn't find the appropriate solution. Please guide us how we can resolve it

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: the blank sidebar. we would like to same widget with every language. But unfortunately currently all the widget disappear on language changing.

Thank you

June 14, 2019 at 2:12 am #4017563

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please check and confirm that these widgets are set to display on all languages?

Documentation: https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

If the issue persist after following the guide above, could you please check if this issue occurs when:

- All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Sixteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Note: Please backup your site completely before doing this test.

Please share to me your results on the above test.

Also, could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Kind regards,
Dennis

June 14, 2019 at 10:42 am #4020623

johannesG-8

We setup the widget with all language. And when we deactivate WPML plugin website working fine. We debug this issue in detail after it contact with you. Need your assistance on it. Please reply us as early as possible

June 14, 2019 at 10:44 am #4020625

johannesG-8

This issue occur when the language parameter attached with URL like: ?lang=nl

June 17, 2019 at 3:08 am #4031779

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

June 18, 2019 at 6:52 am #4040773

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the access details.

After several attempts, finally I was able to generate a duplicator package of your site. I will download a copy and try deploy it on my local tests environment. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

June 18, 2019 at 2:49 pm #4044563

johannesG-8

Hi,

Please check my private reply. You have every type of access related to website testing. You can play on our demo server instead of setup a website locally.

Is there any chance we try to resolve that issue as early as possible.

Thank you

June 19, 2019 at 8:15 am #4049319

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

It seems that the issue is related to WooCommerce plugin. It seems that the issue was caused by missing WooCommerce tables. You can check it on WooCommerce > Status > Database section. Among the missing tables includes 'min_woocommerce_attribute_taxonomies' which store the attributes data. Please see attached image.

Could you please try to fix this? I'm not sure if it will work but you may try the 'Update database' option on WooCommerce > Status > tools tab to fix this.

Hope this helps.

Kind regards,
Dennis

June 19, 2019 at 11:40 am #4051219

johannesG-8

Hi Dennis,

We have been updated all the woo-commerce related stuff. Please check it.
We are waiting your assistance on our query.

Thank you.

June 20, 2019 at 8:14 am #4057561

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

First of all, you need to translate your attribute terms at WooCommerce > WooCommerce Multilingual > Attributes tab and select the attribute to translate. After translating the attribute terms, click the button 'Synchronize attributes and update product variations'

Then, translate the products to your secondary language (Dutch).

I have created a test product following the steps above and the sidebar is now populated with the attribute filter.

hidden link

Hope this helps.

Kind regards,
Dennis

June 20, 2019 at 3:26 pm #4060967

johannesG-8

Hi Dennis,

Hope you are doing great.

Thanks you provide us the solution on our query.
Actually we want to translate the products Without duplicate the products. All the values are same in every language. Only title changing required so we have solution for it. We can create .po (translated file) for it. If you have any other solution please assist us.

So how we can show attribute search(sidebar on the product listing page) without changing the attribute language.

Thank you

June 21, 2019 at 9:13 am #4065625

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply and clarifications.

You can try set all product Attributes to 'Translatable - use translation if available or fallback to default language' at WPML > Settings > Taxonomies Translation section.

Then, on WooCommerce > WooCommerce Multi-lingual > Attributes tab and select the attribute and just click the button 'Synchronize attributes and update product variations'

Related documentation:

https://wpml.org/documentation/related-projects/woocommerce-multilingual/displaying-untranslated-products-in-secondary-languages/

Kind regards,
Dennis

June 21, 2019 at 6:33 pm #4068897

johannesG-8

Hi Dennis,

We didn't find the 'Translatable - use translation if available or fallback to default language' under the Translation Management. Can you please guide us how we can do that. How we show the sidebar without duplicate the products.

Screenshot: Didn't find under the translation management.
hidden link

Thank you

June 24, 2019 at 3:02 am #4074135

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

You should be able to find it at WPML > Settings > Taxonomies Translation section. Kindly check attached images.

Kind regards,
Dennis

The topic ‘[Closed] filter products by attribute widget disappear on language changing’ is closed to new replies.