This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by gunnarB-5 2 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 20, 2019 at 8:38 am #4057701

gunnarB-5

I am running WPML on WordPress.com and one of my plugins is using WPML filter to filter categories based on WPML language:

private static function remove_language_category( $category_id, $current_lang ) {
   $args = array('element_id' => $category_id, 'element_type' => 'category' );
   $my_category_language_code = apply_filters( 'wpml_element_language_code', null, $args );
   return $my_category_language_code != $current_lang;
}

However in wordpress.com the following filter does not return the selected language (based on logging that I added to the code):

$my_category_language_code = apply_filters( 'wpml_element_language_code', null, $args );

The filter returns an empty string.

I had my WPML configuration verified by WPML team already and this issue still persist. Please advise why this filter does not work on wordpress.com.

June 21, 2019 at 8:53 am #4065575

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be a compatibility issue. To debug the issue further without affecting your live site I have created a test site in our Sandbox server. It is a fresh installation. Please check the following link.

hidden link

Please upload and configure the required plugins and your theme. Then check the issue is reproducible or not. It will help us a lot and we can forward it easily our developers for further debugging.

Also please let me know the steps to reproduce the issue on your site.

--
Thanks!

Bigul

June 25, 2019 at 9:04 am #4082491

gunnarB-5

Hi,
I've configured WPML and added the the Echo KB plugin and their Elegant Layout add on and it worked. But as soon as I activated JetPack (which is required for my theme Arcane (hidden link)), the Elegant Layout stopped working, as it does on my live site.

I've not added my theme since it seems I have to pay for it again in order to install it in the sandbox environment. I just have the free version of JetPack but I have paid for the theme.

Is there a known compatibility issue with JetPack for WordPress.com?

June 25, 2019 at 12:28 pm #4084547

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and setting the Sandbox site. But sorry I am not able to reproduce the issue exactly. So please share the steps to reproduce the issue.

--
Thanks!

Bigul

June 25, 2019 at 12:42 pm #4084623

gunnarB-5

Hi,
To reproduce the issue:
1. Under Knowledge Base/Configuration/Overview you can toggle WPML Enabled/or not
2. With WPML not enabled the categories from Echo KB's Elegant Layout add-on shows up under Knowledge Base/Configuration/Main Page (and on the published KB start page)
3. With WPML enabled the categories no longer shows up (either under Configuration or on the published KB)

I've been in contact with Echo KB's support and Srdjan Jocić from WPML Compatibility Team and they pointed me here for debug.

June 25, 2019 at 3:51 pm #4086109

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I have reproduced the issue and escalated the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

June 26, 2019 at 3:18 pm #4093559

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, we are getting the expected result on the Sandbox site after the following steps.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Please check the Sandbox test site and let me know your feedback.

--
Thanks!

Bigul

June 27, 2019 at 8:21 am #4097783

gunnarB-5

Hmm, thanks for you quick answer. It seems to be working in the Sandbox as you say, but when I make the same "Clean-up" in my live environment the issue persists.

In both environments the "Fix WPML tables collation" command does not return a confirmation pop up. There is only a quick progress animation and then nothing.

June 27, 2019 at 3:05 pm #4101147

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

June 27, 2019 at 3:27 pm #4101295

gunnarB-5

The site is hosted on wordpress.com and I've previously provided Srdjan Jocić from WMPL with Admin access to the site. If you provide me with your e-mail address I can send you an invite to the site as well.

June 27, 2019 at 7:48 pm #4102669

gunnarB-5

Thanks. Invite has been sent to your e-mail address.

June 28, 2019 at 12:04 pm #4107181

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have shared the details with our compatibility team. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 1, 2019 at 8:05 am #4116245

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, because of the settings(Jetpack), we are not able to login to your site now. Please check.

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on our local server.

--
Thanks!

Bigul

July 1, 2019 at 8:44 am #4116687

gunnarB-5

Hi,
I've changed what I think it the setting needed to be changed in Jetpack (match e-mail addresses). It did work for Srdjan Jocić to login with the same invite.

When I try to activate the Duplicator plugin I get the following error message: ""duplicator" has been deactivated, it deletes data necessary to manage your site and is not supported on WordPress.com."

July 2, 2019 at 8:42 am #4125011

gunnarB-5

Hmm, that's strange, I get wrong password when I try with your credentials.

I removed you as a user and sent a new invite. Hopefully it will work again with that.