Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

Filters by Attributes are not displayed.

Solution:

1- Go to WooCommerce → Status → Tools.

2- Click on the language switcher at the top of the screen and switch to the secondary language.

3- Look for the section to Regenerate the product attributes lookup table.

4- Search for the product you want to fix and click the Regenerate button.

Alternatively, you can disable that feature:

1- Go to WooCommerce → Settings → Products → Advanced.
2- Uncheck the Enable table usage option.

Relevant Documentation:

https://wpml.org/errata/woocommerce-6-3-the-new-product-attributes-lookup-table-is-not-populated-for-products-in-secondary-language/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by maciejM-19 1 month, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
June 13, 2022 at 11:13 am #11448471

maciejM-19

I am trying to:
There are elements in my e-shop:
- products with attributes. Attributes are translated to MNE (Montenegrin) language.
For example, product 'Men’s city bicycle JOHNNY LOCO BRIGHTON 28/56/M. Color: blue' (hidden link). See picture 'JOHNNY LOCO.JPG'
- filters by Attributes in Sidebar Left Product ('Sidebar Left Product.jpg'). Translation of filters is completed ('Filters_translation.jpg')
I am trying to open a page with filters in MNE

Link to a page where the issue can be seen:
hidden link

I expected to see page with filters as in EN ('EN_Page with filters.jpg')

Instead, I got a page without filters ('MNE_No filters page.jpg')

EN_Page with filters.jpg
MNE_No filters page.jpg
JOHNNY LOCO.jpg
Sidebar Left Product.jpg
Filters_translation.jpg
June 13, 2022 at 12:14 pm #11448997

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

1) Could you please check this page and apply the workaround mentioned? (https://wpml.org/errata/woocommerce-6-3-the-new-product-attributes-lookup-table-is-not-populated-for-products-in-secondary-language/)

2) Please make sure that you use the latest version of WPML plugins. You can find the latest version here. (https://wpml.org/account/downloads/)

3) Could you please share your Debug information with me?
You can read a detailed explanation about it here. (http://wpml.org/faq/provide-debug-information-faster-support)
The debug info will give me a lot of information about how your site is configured.

Best regards,
Osama

June 18, 2022 at 10:23 pm #11490983

maciejM-19

Hi Osama,
Thank you. Advised solution fixed the issue.