Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Yvette 3 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
February 22, 2021 at 3:32 pm #8146407

tessH-2

Hi,

If u look at the website in the Dutch or UK version menu item SHOP, you see 2 filters. Colourgroup and sizegroup.
hidden link and hidden link

In the German version of the website u can see that colorgroup does work but size is not showing.

hidden link

if you want i can make a user account for you

February 23, 2021 at 2:29 pm #8155035

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello

Yes, this would be helpful.

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

February 23, 2021 at 6:25 pm #8156831

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

It seems like you have a separate Taxonomy for each language - and that each of these taxonomies have their set of terms.

I would have expected to see one Taxonomy with terms translated to all languages.

Could you please visit here and tell me which are the attributes that you expect to see in the widget?
Product > Attributes

Please specify the name for each language since you do not have the terms translated to all languages.

Thanks

WhichAttributeIsCorrect?.png
February 23, 2021 at 6:45 pm #8156993

tessH-2

Indeed they are, it is used for English and German
Colorgroup filter works correctly
So I don't think there is a difference between colourgroup and sizegroup there

February 23, 2021 at 6:55 pm #8157003

tessH-2

The weird thing is that colourgroup does work. Everthing is the same in colorgorup and size group (the german versions) but it just doest show

February 24, 2021 at 9:26 am #8160835

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

I believe this is because you have no terms created in German for sizegroup (see images)

You don´t have Dutch terms created either, but you have created a different set of taxonomy terms for the Dutch products which I´m confused about.

But, if you duplicate your Sizegroup terms to German and then sync your translations so that the German products are assigned to it, then the filter should work.

However, I repeat that the EXPECTED way to see this is that you would only have a single taxonomy "Colorgroup" / "Sizegroup" where terms would exist in all languages. Right now you have "Colorgroup" for English and German...and then Kleurgroupe for Dutch. This is not ususal and might cause issues with product filtering since the attributes are different.

ConfusingMixedUp.png
Colorgroup.png
Sizegroup.png
February 24, 2021 at 5:25 pm #8166219

tessH-2

Hi Yvet, I did the whole import again today and it keeps going wrong.

The colors are available in 3 languages ​​but the sizes are identical for all 3 languages. maybe that has something to do with it?

February 24, 2021 at 6:22 pm #8166533

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

You are importing the taxonomies? What tool are you using?

You wrote:" The colors are available in 3 languages ​​but the sizes are identical for all 3 languages."

Then I would expect to see the following taxonomies:
"Colorgroup" (translatable) with terms translated to 3 languages.
"Sizegroup" (not translatable) with terms in system default language.

You set the "translatable" / "not translatable" here:
WPML > Settings > Taxonomy Translation

February 24, 2021 at 6:40 pm #8166659

tessH-2

Its called all import i gues. I had a company do that part because im a webdesigner and not really into the deep stuff haha.

Yes, it came like this with the import and nobody here understands why. Is there a way to fix it?

You set the "translatable" / "not translatable" here:
WPML > Settings > Taxonomy Translation

Or is this just the setting and than it works?

February 24, 2021 at 6:57 pm #8166743

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

So I think this is one of the issues.

Please read this documentation:
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#importing-posts-with-taxonomies

It seems that they imported the taxonomies but then did not link them as described in this section: Matching taxonomy translations after import

Please read and see if this makes sense to you.

The topic ‘[Closed] filters in productgroup’ is closed to new replies.