Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Bigul 15 hours, 46 minutes ago.

Assigned support staff: Bigul.

Author Posts
October 29, 2019 at 11:20 am #4846801

janeO

We have a recurring (and very frustrating problem) with finished translations not showing on the front end.

This is our process:
1) open the advanced translator from the Wp> All Pages page
2) made changes
3) check that sentences are showing the green bar so that we know they saved and "completed"
4) click the finish button
5) click the redeliver button
6) see the success message 100 per cent complete
7) purge the site cache
8) clear the browser cache
9) updated Text still does not show on site ( not all pages - some pages work and some don't). See the example picture - we can see that on the new text the final words are cong viec. and on the front end of the site the old text is still showing.

https://wpml.org/wp-content/uploads/2019/10/4842441-darrell_translations_not_showing_on_front_end.jpg

October 29, 2019 at 11:49 am #4847113

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please try the following steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In the Troubleshooting page, please click on the *Clear the cache in WPML* option of the *Clean up* section. Wait for confirmation of processing.
4) Open the Page having an issue in the default language for edit
5) Make a minor change in the page contents and update the page. It will help us to refresh the translation settings
6) Update the translation

--
Thanks!

Bigul

October 29, 2019 at 5:23 pm #4850699

janeO

Hi Bigul:

I followed the 6 steps outlined above. In addition, I also had our host (siteground) upgrade the wp memory limit to 768. And... I also purged the server cache and cleared the cache in my browser and the page content is still showing the old translation. I tried testing in two browsers, clearing the cache in both.

October 30, 2019 at 12:44 pm #4855697

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am checking about the issue with our team now. Please check you have any server-side caches. If so, please clear it and make sure the bug is existing or not.

--
Thanks!

Bigul

October 30, 2019 at 5:38 pm #4858463

janeO

We are using siteground and the SG optimizer. I turned memcache off as I read in the forum that it was suspected that it could be adding to issues. I have purged the dynamic cache in the sgoptimer pretty much every time I checked the page. I also cleared my browser caches (checked in both ie and chrome and sometimes firefox). Content still not showing.

October 31, 2019 at 11:11 am #4862939

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please share the URL of a couple of Page or Products having the issue.

--
Thanks!

Bigul

November 1, 2019 at 11:10 am #4870093

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information and details. For example, I checked this hidden link product. But not able to see the missing part exactly. So can you please share a screenshot for a better understanding.

I have one more request. There are many changes/improvements in the working of Advanced Translation Editor in WPML 4.3. So we would like to make sure the issues are existing in the latest version of the plugin(4.3.2) or not. Because of the version compatibility also. Therefore please upgrade to the latest version of the plugin on the staging site and make sure the issue is existing or not.

--
Thanks!

Bigul

November 1, 2019 at 5:59 pm #4872689
janeO

I updated the plugins on staging and as expected our product listings no longer show on the Services for Canadian Students Page or International Student Services page in anything but english. This is why we toasted the updates last time and went back to a clean staging copy.

hidden link
hidden link

You will notice at the bottom of both these page that thereare products displayed - try changing to any other language - the products no longer display.

At this point it looks like the translations have updated. How long does it normally take for a translation to show up?

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/our-product-listings-no-longer-show-on-the-services-page/

November 1, 2019 at 6:00 pm #4872715

janeO

sorry the second link with the missing product feed was hidden link

November 4, 2019 at 7:27 am #4878275

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Maybe the updated translation was not showing in the frontend because of the caches. Because normally it will display in the frontend without a delay. Now translations are showing as expected for all the pages and products, am I right?

Have you changed the user name or password of the staging site? Because now I get *The username or password you entered is incorrect.* error.

I am enabling the private option for the next reply. Please share with me the credentials for further checking.

--
Thanks!

Bigul

November 5, 2019 at 6:27 am #4885813

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details and login information. I have opened a new ticket for the product listings no longer show on the Services pages issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

To track the updated translation not showing issue please try the following steps and let me know how much time it is taking to show the translation. It will help us to check it with our Advance Translation Editor team with more data.

1) Upgrade to WPML 4.3.3(we have released a new version yesterday) on your staging site
2) Please create a test product
3) Translate it to secondary language
4) Update the original
5) Update the translation

--
Thanks!

Bigul

November 6, 2019 at 8:18 pm #4901605

janeO

Hi Bigul:

I have an existing page that I updated the translation on early yesterday - hidden link

and even after purging the site cache and clearing my browser cache the updated page is not showing the new content in vietnamese. So over 24 hours at this point.

Is there something else I should be clearing.

I also have a question about your instructions from your last response.

1) Upgrade to WPML 4.3.3(we have released a new version yesterday) on your staging site (DONE)
2) Please create a test product
3) Translate it to secondary language
4) Update the original - what do you mean update the original? You have to update the original after you translate something - how do you do that?
5) Update the translation

November 7, 2019 at 8:00 am #4903321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have requested the following steps because I thought these are the steps you are following to reproduce the issue and you have update the translated post/page after updating the original language post/page. We don't have to update the original language post or page after updating the translation.

1) Please create a test product
2) Translate it to secondary language
3) Update the original
4) Update the translation

So the issue is happening when you update the translated post(for example like correcting the translation), am I right?

--
Thanks!

Bigul

November 12, 2019 at 11:00 pm #4935199

janeO

Hi Bigul:

1) Please create a test product
2) Translate it to secondary language
3) Update the original - what do you mean update the original?????
4) Update the translation

Also I saw this on our updates page - is this something that might be part of the problem we are experiencing (see uploaded image) Translations New Translations are Available and a button to update translations (I don't know whether this is a system generated message or something to do with the actual translations we have made.

I understand from our translator that "Prices are in Canadian Funds" is not showing correctly on our product pages even though she made the changes quite some time ago.

November 13, 2019 at 11:45 am #4938405

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am checking the issue with our team(for the expert opinion). Please share the URL for the post having this issue now. So I can share it with my team.

--
Thanks!

Bigul