This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translated Posts and Pages are immediately published, rather than being saved as Drafts.

Solution: This is expected behavior for translations. This behavior can be changed by using the following steps:

  • Go to WPML -> Settings and scroll down to the "Translated documents options" screen
  • Change the "Document Status" setting to "Draft" as shown below
  • Click the "Save" button under the setting

Now, when you create a translation for any post, it will be saved as a draft until you publish it.

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by paulaD-8 3 weeks, 4 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 20, 2019 at 2:24 am #4608729

paulaD-8

Hi!
I need to check if I'm doing things correctly when translating a post.

I've written a post in Spanish, then I click Language > English (Add English translation).

When I finish translating with the Advanced Translator Editor, I click Finish. BUT, I don't click in Complete, as it has happened that the post gets published, and I do not want that. I would like to review the English post and make further changes.

So when I click on Complete, I go back to the Spanish post, and I choose the English version, the translation is not there.

Can you provide any supporting documentation on how to finish a translation without posting it?

My site is hidden link.

Cheers,

Paula

September 20, 2019 at 1:09 pm #4612429

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Paula,

Thank you for reaching out to us. There is a WPML setting you need to change:

  • Go to WPML -> Settings and scroll down to the "Translated documents options" screen
  • Change the "Document Status" setting to "Draft" as shown below
  • Click the "Save" button under the setting

Now, when you create a translation for any post, it will be saved as a draft until you publish it.

I hope that solves your problem. Please don’t hesitate to reach out if you have further issues!

September 22, 2019 at 10:49 am #4618163

paulaD-8

My issue is resolved now. Thank you!