This thread is resolved. Here is a description of the problem and solution.

Problem:Fix links created in String Translation

Solution:Issue is being continued in the following thread

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bobby 1 year ago.

Assigned support staff: Bobby.

Author Posts
May 10, 2019 at 3:35 pm #3786287



I have a site where we duplicate all the pages/posts so we preserve the user inside the translated site even if the page displayed is not translated. There are a lot of links from those duplicate pages that go back to the original language (English): sometimes it is the original link, some other times is something like /?page_id=xx or /?p=xx.

We found out that we had some links with HTTPS, some others with HTTP. So we did a search/replace, then, re-duplicate all the duplicate pages, but that didn't fix the links and it is because in STRING TRANSLATION it is already defined and not updated.
We also use the "Translate Link Targets" under settings, but we found out that links aren't fixed there because in the table "wp_icl_strings" those links are marked as LINE and not LINK. We believe that it is because they are not identified as internal link because they don't have HTTPS.

Only when we save the page, then go to String translation and click save translation that fixes the problem, but we cannot do that for all the duplicate pages/post because they are a lot. So we are seeking for an alternative solution on this.

Thank you.

May 10, 2019 at 7:40 pm #3787697


Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

[duplicate ticket ]
Issue is being continued in the following thread