This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.83 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by Jamal 4 weeks, 1 day ago.

Assigned support staff: Jamal.

Author Posts
September 10, 2019 at 4:09 am

catalinaL

Hello
In the store there is two languages, Spanish and English. All translation is working fine, rather than the fixed price shipping rate. On the cart page (also on checkout page) while language is selected English shipping price is applied, while choose Spanish no shipping price show(for international shipping). I have checked all translation and settings, but no success. Please help me
Thanks in advance

September 10, 2019 at 5:16 am
September 10, 2019 at 1:18 pm #4545653

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I checked the issue and I would like you to further analyze it on my local computer. Would you allow me to take a Duplicator package of your site?

Best regards,
Jamal

September 11, 2019 at 12:10 pm #4553285

catalinaL

yes please
I need to fix this as soon as possible.

September 12, 2019 at 3:56 am #4558077

catalinaL

Hello
Is there any news about the issue?
Please help me to resolve this issue, i really need to fix this

September 12, 2019 at 11:20 am
September 12, 2019 at 11:21 am #4560451

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies for the late reply. I was on sick leave yesterday and the team must have missed my queue to give the ticket to another supporter.

I tried to create a Duplicator package, to no avail. I thought it is because of Wordfence, but it did not work even if I deactivated Wordfence temporarily.

Please follow the instruction I sent you in my previous private message(SEPTEMBER 12, 2019 AT 11:20 AM) to migrate your website to our infrastructure. That would be helpful if I needed the assistance of our developers.

Best regards,
Jamal

September 13, 2019 at 4:26 am #4565513

catalinaL

Hello
I have migrated the site as per instruction. Please have a look on the issue and please help me to sort this.
Thanks

September 13, 2019 at 2:04 pm #4569229

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your efforts. The website was not stable and I could not open it until I deactivated the plugin "bis-mega-enterprise-platform", see the attached image.

Even in a minimal setup, with a default theme and minimal plugins, the issue was still appearing, I edited and saved all shipping methods, to no avail.

I am approaching our second-tier team to help us resolve this issue. I'll get back to you as soon as possible.

Best regards,
Jamal

September 14, 2019 at 6:48 am #4572311

catalinaL

Thanks for your response
I want to resolve this issue as soon as possible please.

September 16, 2019 at 8:29 am #4577399

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

this may also be a bug, would you please try to reproduce this issue in a clean install. I created a new test server, which you can log in to it following this URL.
hidden link

Please configure WPML(languages), WooCommerce(Shipping zones) and WooCommerce Multilingual(currencies) and check if the issue will be present on this install. If it is present, I'll escalate it to our developers.

Thank you for your collaboration.

Best regards,
Jamal

September 18, 2019 at 10:06 am #4594809

catalinaL

Hello I have setup all setting of wpml and woocommerce multilangual
I have just translated the one product here is the link
hidden link
But it show the currency usd0 for "Spanish" and working fine for the "English" language. as for the "English" language shipping is working fine on cart page. and for the "Spanish" language it show 0.01 international shipping.

September 19, 2019 at 11:52 am #4604367

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your collaboration. The issue was reproduced in this clean install too. I am escalating it to our 2nd Tier team for further analysis and possible escalation to our developers.
I'll get back to you as soon as possible.

Best regards,
Jamal

September 20, 2019 at 2:56 pm #4613143

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

According to our 2nd Tier team, there is no issue at all but there are some "wrong" settings.

In WooCommerce Multilingual->Multicurrency, 1 USD was set to 0.00029 COP so 35 USD will be 0.01015 COP and then the Number of Decimals was set to 0 which mean 0.01015 will become 0

As of today, 1 USD to COP is 3,392.55. You may need to update this rate.

If you want shipping cost in decimals then enable the decimals as long as you wish.

Please check the test server to see hidden link

Best regards,
Jamal

The topic ‘[Closed] fixed rate shipping of woocommerce products’ is closed to new replies.