This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bobby 9 months ago.

Assigned support staff: Bobby.

Author Posts
January 12, 2019 at 12:02 am #3082124

yanw-3

I activate the plugin in my local test. After I tested custom icons, I found the flags are messed up.

January 12, 2019 at 1:35 am #3082232

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

what are your results when using a default theme such as Twenty16 ?

did you add a custom language switcher or just a menu language switcher from within WPML->Languages ?

January 13, 2019 at 3:06 am #3084032

yanw-3

Yes it shows same in the default theme. Also I changed the flag image from zh.png to zh-cn.flag, then the flag shows up. Actually I don’t believe your company didn’t fix this bug. But I met another problem: I try to create a drop down list for the language switch in the menu. I used the menu editor provided by the plug in. But unfortunately it never worked. It keeps show two flags next to each other.

January 14, 2019 at 5:49 pm #3089210

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

are you manually uploading a custom flag ? going into
wp-content/plugins/sitepress-multilingual-cms/res/flags/ you can see that there are 2 flags with cn.png and zh.png

regarding the drop down if possible i would like to take a closer look as i have not been able to reproduce this issue on a clean environment

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

January 15, 2019 at 1:06 am #3090187

yanw-3

I am migrate the site to a public server. Before that I worked on local test. I will install WPML directly on the server to see if the the error still was there. if there is still same error, I will grant temporary access to you.

To answer your previous question:
I installed the WPML, set up 2 languages (English and Chinese). The first look was OK - both icons showing up. I found the default English icon is British but I wanted to show USA. So I uploaded the custom icons. Then the flag icon messed up. The Chinese icon disappeared. I then steichen back to the default icons, the error was there still. I deactivated the plugin, then reactivated, the error was still there. Now I found the drop down list didn't show up, there always just two icons side by side. I then changed the name of zh.png to zh-cn.png, the Chinese icon appeared again.

Also I don't like to call the Chinese language "Zh", I'd like it shows as CN. So the url could be hidden link and hidden link.

January 15, 2019 at 9:28 am #3091644

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

thank you for the additional information !

I understand , the best way to achieve switching ZH to CN would be to create a new "custom " language from within WPML->Languages

bellow are my tips when it comes to uploading a custom flag to WPML if you experience the issue you are experiencing

1. within wp-content/sitepress-multilingual-cms/res/flags you can upload you custom flag with a name such as cn.png (make sure its not a duplicate of a name that exists already)

2. then add you custom language from WPML->Languages->Edit languages

3. This is a debugging step in case the flag does not show or shows up broken in the front end/backend

Go to your database and view the table wp_icl_languages and verify that the new custom language has been added correctly to the database , if this checks out move the next step

go to wp_icl_flags and now verify that there is an entry for the new language (check the language code) that corresponds to the correct flag you uploaded earlier

let me know your results please and if the issue continues once you migrate to a live server i can enable the private field to share access with me to take a closer look

The topic ‘[Closed] flag icon messed up’ is closed to new replies.