This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.84 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: flag link is not linked to language home or homepage language switcher goes to 404

Solution: Please check these:

1. did you translate your home page 100% and completed it? 2. did you publish the translation or it is a draft? 3. are you able to fix this if you follow this? : - When you go to Setting > Readings to set the static homepage - At the top make sure the language is selected to be HU and then choose the HU translations of homepage of HU

This topic contains 2 replies, has 2 voices.

Last updated by pauloF-2 2 weeks, 5 days ago.

Assigned support staff: Riffaz.

Author Posts
September 30, 2019 at 10:33 am #4663745

pauloF-2

I am trying to: use HU Flag to switch language

Link to a page where the issue can be seen: hidden link

I expected to see: HU Language Home - hidden link

Instead, I got: Link to Achive Page (screenshot) specialy on mobile

https://wpml.org/forums/topic/flag-link-dont-link-to-home/#post-4662799

September 30, 2019 at 10:54 am #4663877

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I see that /hu/ home page is not found, it goes to 404: hidden link

1. did you translate your home page 100% and completed it?
2. did you publish the translation or it is a draft?
3. are you able to fix this if you follow this? :
- When you go to Setting > Readings to set the static homepage
- At the top make sure the language is selected to be HU and then choose the HU translations of homepage of HU

Let me know how it goes.

Regards,
Riffaz.

September 30, 2019 at 11:22 am #4664053

pauloF-2

My issue is resolved now. Thank you!