This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.87 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by ioannisR-4 1 year ago.

Assigned support staff: Bobby.

Author Posts
September 30, 2018 at 8:30 am

ioannisR-4

Hello,

the flags are displaying normal in all pages except of the home page that have dissappeared. When I am logged in as admin flags appears at home page too.

October 1, 2018 at 5:01 pm #2778912

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. What are your results if you go to WPML->languages->add footer language switcher

- do you see the footer language switcher in the front end ? (when signed out)

2. Please verify that the front end page is fully translated and also set to status " published" and not draft or private for both default and translation languages.

let me know your results

October 1, 2018 at 5:45 pm #2779047

ioannisR-4

Hello,

1. Footer menu has the same result. It is not visible in the home page.

2. I verify that front end page is fully translated and published.

Thank you

October 2, 2018 at 5:47 am #2780371

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

is your theme a custom theme ? There is a chance that this is being caused by an incompatibility with either a 3rd party plugin or the theme.

to test this we recommend testing with a minimal environment on a staging/test site performing the following steps.

-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

if this is not possible and you do not have a staging/test site then we will need to create a duplicator package to test your site locally where the live site will not be affected by deactivating plugins and/or the theme test.

October 2, 2018 at 5:57 am #2780377

ioannisR-4

Hello,

I am using a very popular theme with thousands of installations. I have tried to switch to a wordpress default theme and deactivate other plugins but the problem persists.

Thank you

October 2, 2018 at 6:55 pm #2782550

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look

i tried using the credentials provided in your first reply but they are not working for me at the moment.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

October 3, 2018 at 3:31 pm
October 3, 2018 at 8:19 pm #2785703

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

thank you for providing me with access !

i can see within your pages there are about 72 pages in the trash, if possible please clear your trash, as this can cause some issues

additionally i noticed that when i visit the front end using the secondary language even when i am not signed in i can see the language switcher therefore the issue is only on hidden link

now the weird solution is that if i go to WPML->languages-> activate checkbox for "Use directory for default language" which changes the default language homepage URL to hidden link then it works as expected.

i suspect this might be happening due to some cache on the server or even a custom htaccess code as i am not able to reproduce the issue with a clean enviroment and a copy of flatsome theme on my localhost.

October 4, 2018 at 7:41 am #2786567

ioannisR-4

My issue is resolved now. It was .htacess problem. Thank you!