This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 15 replies, has 2 voices.

Last updated by Marcel 3 months, 2 weeks ago.

Assigned support staff: Marcel.

Author Posts
December 9, 2019 at 4:30 pm

daniC

I am not able to see the language switcher on the mobile version of my website: hidden link

Pleased let me know why this is happening and fix it.
Thank you.

December 9, 2019 at 5:18 pm #5094659

daniC

I went through the checklist and I still need assistance.

Thank you.

December 11, 2019 at 9:35 am #5104897

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I activated the "Mobile Menu" checkbox inside your Main Menu, but it's not working, even not with an own CSS Media Query

You can add a Menu Language Switcher to your main menu under Appearance - Menus from the left selection which will target that specific menu. This can be seen here: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#full-control-over-each-language-switcher

More information you will find here: https://wpml.org/forums/topic/language-switcher-on-mobile-menu/#post-1529077

Let me know if it's working for you.

Best Marcel

December 11, 2019 at 2:38 pm #5107877

daniC

Hi Marcel,

This is all very confusing for me. Can you please just go ahead and add the flags to the mobile version of my website? I would really appreciate your help.

Thank you so much.

December 12, 2019 at 2:11 pm #5115815

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I tried to add it, but your Theme is not recognising the mobile switcher option. It works using the WordPress standard Theme.

Please upload your Theme here on this isolated Sandbox environment hidden link and I will try to reproduce this on the Sandbox.

Then we see if it's a bug in The7 Theme or if it's happening only on your installation to check the further steps. WPML is already pre-configured like on your installation

Please let me know.

Best Marcel

December 12, 2019 at 3:20 pm #5116491

daniC

Hi Marcel,

So I clicked on the link you sent me. Some kind of theme duplicator seems to have been created. Here are the login credentials that were generated:

Login: hidden link
Username: demo
Password: 5EU8ugtE4Lz9

I hope you can fix this issue now. My client is really upset and I need to fix this urgently.
Please let me know if there is anything else you need.

I look forward to hearing from you asap and I thank you for you prompt attention to this urgent matter.

Regards,
Mary

December 12, 2019 at 6:38 pm #5118241

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mary,

My link is opening this credentials directly for you as a “One Click Installation”, so the credentials you send are not necessary.

Please upload now your Theme here and I can try if I can reproduce the issue.

Thanks
Best Marcel

December 12, 2019 at 7:19 pm #5118321

daniC

Hi Marcel,

Ok so I installed my theme. Please let me know if you need anything else.
Thank you.

December 13, 2019 at 2:46 pm #5124083

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mary,

thanks, I was able to get the language switcher instantly working on the test site. So, there is no general bug and the issue happens only on your site.

Do you have a Staging site where we can deactivate other components to locate the culprit on your site? If no, please let me know and I can provide you a Cloudways copy for further debugging.

Working demo: (check with a mobile device or Browser Tools -> F12)
hidden link

Best Marcel

December 13, 2019 at 3:03 pm #5124333

daniC

Hi Marcel,

So I guess this is good news 🙂
I do not have a testing site, and I do not know how Cloudways works.
Please just go ahead and proceed with whatever you need to do to fix the issue.
You have my permission to trouble shoot and see which other plugin is causing the problem.
I just really need this done as soon as possible.

Thanks so much once again.
Regards,
Mary.

December 13, 2019 at 4:38 pm #5124967

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi, removing the duplicate "home anchor" menu and assigning "Talent Co Main_English" as new "Primary Manu " & "Mobile Menu" solved the issue.

I'm not sure why it was duplicated, but anyway, the content which was included was not identical between both menus. Everything seems to works as expected after this. For reference, the menu I deleted contained these Custom Links entries:

Home
#!/up

#!/about
About Us

#!/services
Services

#!/team
Team

#!/process
Our Approach

#!/contact
Contact

Working site:
Please check hidden link (please check with a mobile device or Browser Tools -> F12)

Best Marcel

December 13, 2019 at 6:17 pm #5125535

daniC

Hi Marcel,

Thank you so much for your great work.

Ok, so I see both flags are there now on the mobile, but they are only visible on the English side. When I go to the french side and click on the drop down menu of the french side, I do not see any of my page tabs or language flags.

Please fix the french side too.

Thanks so much.

Regards,
Mary

December 13, 2019 at 6:23 pm #5125545

daniC

Hi Marcel, I think I just fixed it 🙂
Please verify and let me know.

Thank you so much!!

December 13, 2019 at 6:30 pm #5125553

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mary,

If I click the french flag, I can see everything as expected. Could you please provide me with a screenshot for a better understanding of what you see?

Thanks
Best Marcel

December 13, 2019 at 7:17 pm #5125843

daniC

Hi Marcel,

I wrote to you earlier saying that I think I fixed it 🙂
It looks like everything is working great now.

Thanks again for all your help.

Regards,
Mary