This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Lauren 3 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
June 18, 2019 at 4:03 pm

nourD

Hi,

The website I'm working on was almost ready to go. Everything was working fine in both languages when suddenly the flags disappeared from the Right Top nav Bar where I had them. Trying to figure out what happened I went to Languages in the WPML options and added the flags again. This time through Widget Language selector; the flags appear in the right place but when clicked on them it only shows the content in one language (whatever the language the link had). Example: If I arrive to the Home page in Spanish through direct link then every time I click the any of the flags the page reloads with the same language (in this case Spanish). If I go to the Home page (in English) through direct link and press the any of the flags, then the page reloads and keeps showing content in English. Actually it seems this only happens with the Home page and Inicio page (which are the both language versions for the landing page)
So the content translated content is till there, but flags are not responding properly.
Can you please help me out figure out what's going on?

Link to a page where the issue can be seen: hidden link

I expected to see: the content in the language of the flag that I choose from the top nav bar right.

Instead, I got: the same language content regardless of the flag that is showing.

June 18, 2019 at 4:37 pm
June 18, 2019 at 4:38 pm #4045337

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have marked the next reply as private so that you can share the duplicator files once you have them available. Thanks!

June 18, 2019 at 7:07 pm
June 19, 2019 at 6:52 pm #4054093

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending over the site files. I was able to set up a copy of your site and found that the issue with the language switcher is coming from your theme. When I deactivate the theme and it's plugins, and switch to Twenty Nineteen, the language switcher works as expected.

I'd like to see if we can reproduce the issue on a clean install. If so, I can send this ticket to our Compatibility team so that they can get in touch with the theme author to see if they would like to become compatible. I've set up a staging site here - can you please upload a copy of your theme so that I can further test?

Login: hidden link
Username: demo
Password: Qn0SoR1a4Oa8

Thanks!

June 19, 2019 at 7:22 pm #4054207

nourD

Thank you so much, Lauren.

Passing along the info to my partner. He will upload it ASAP.
It was kind of a weird problem. The theme says it is compatible and apparently, everything was working find and it was full compatible. It was just at some point probably after Home was completely translated that the Flags first disappear and when we put them back again, they were not working properly with HOME and INICIO.
Crossing fingers and praying.
Let me know if after the upload you need anything else.
Thank you so much.
ND.

June 19, 2019 at 7:50 pm #4054403

nourD

Hi Lauren,

I just uploaded the theme, but didn't active it. Let mw know if it is missing anything.
Thank you so much,
ND

June 20, 2019 at 3:50 pm #4061175

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much, I activated the theme and installed the required plugins but was not able to reproduce the issue. I then went back to the test site that I created from the Duplicator files. I reactivated the plugins one by one and then the theme, and now the issue is not happening. So perhaps something was cleared in a cache when the plugins were disabled? Either way, if you can test these steps on your live site it would be great.

1. Temporarily disable all plugins other than WPML core (the multilingual CMS) and switch to a default theme such as Twenty Nineteen.
2. Go to WPML -> Support -> Troubleshooting and click through the steps in the Cleanup section.
3. Reactivate theme and plugins.

Does the issue still appear after these steps?

June 20, 2019 at 9:28 pm #4063151

nourD

Hi Lauren,

My partner tried following the steps, but apparently it didn't work for him. The page is still showing the issue. I'm not sure if we are missing something. We have a backup. Would you mind entering our site and doing exactly what you did on the test site? Is that possible? Please let me know, and thank you so much for your invaluable help.
ND.

June 21, 2019 at 3:34 pm #4068097

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure I can do that for you. Before I test that, please update to the latest versions of WPML plugins. Also, the WP Memory still has not been increased. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Once those things are done, please let me know and I will disable the plugins and theme, run the clean up steps, and then activate everything again.

June 24, 2019 at 4:34 am #4074413

nourD

Dear Lauren,

Thank you so much. We have updated all the WPML plugins, and my partner added the code to increase the memory, but for some reason it's no doing anything if you still see the limit hasn't increment :-s could we have missed something in the code or something else? Thank you so much for your patience.

June 24, 2019 at 9:37 pm #4079869

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I was able to increase the memory for you. It was just placed in the wrong spot, it was too far down in the file. I moved it and now memory is increased, but that did not resolve the issue.

I did notice that there is a difference in your live site and my test site. In the live site, there is an active plugin in wp-content/mu-plugins called System Plugin. I don't have that in my test site. Do you know where that comes from? It's not on the list of theme required plugins.

June 24, 2019 at 11:09 pm #4080149

nourD

Hi dear Lauren,

Thank you so so much for your patience. My partner tells me that he doesn't see the System Plugin installed on our live site (he says that it is probably in the folder but not installed). And what he sees is that any page he assigns as "Home" acts the same (replicates the problem). Any idea what could be happening? Is there something you would need the FTP info to search further. He mentioned if you can send us the URL for the test site so that he can see help you double check is there is any other difference between the two sites that he can maybe also catch and help.
Thanks again!
Nj.

June 25, 2019 at 12:26 pm #4084475

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I am attaching a couple screenshots so that you can see where the systems plugin is located. It may not be related, but since I don't have it on my test copy, I can't look at its contents. If you go to Plugins, in the links at the top of the list of plugins, there is a "must use". Click that and you can see the systems plugin. It is automatically executed since it is in the Must Use folder.

Also, please check the wp-config to see if you are defining the homepage URL there. If so, try removing that and see if there is any difference. Also check the .htaccess file and see if there are any redirects set there. I'll be happy to take a look at these files as well if you would like to allow me FTP access.

The test site is currently on my local server, but if you would like, I can set up a staging site and migrate your site there so that your developer can take a look. Just let me know and I'll be happy to do that.

You can edit your previous private reply and add FTP credentials if you would like.

June 26, 2019 at 2:38 pm #4093295

nourD

Hi Dear Lauren,

I have uploaded the FTP info and a new message on one private message above. Thank you so much for you help and patience.
Nj.