This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Rohan Sadanandan 2 months, 1 week ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 13, 2019 at 9:14 pm #4390821

marcoB-114

Tell us what you are trying to do?
Hi I installed the WMPL, I configured two languages, English and Russian, and it is all ok, in each page I can see the flags switcher....

hidden link

but not into blog post where I have just a language, not both.

hidden link

How I can solve?

August 14, 2019 at 11:55 am #4394621

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

The language is not showing in the language switcher because you may not have created the translation for the post.

If that is the case & you still want to show the language in the language switcher, please navigate to WPML > Languages > Language switcher options and select "Link to home of language for missing translations"

Also please make sure that the page/post is set to translatable in WPML > Settings > Post Types Translation

Please let me know whether this works for you.

Thanks,
Rohan