Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When i have shipping classes setup, they are calculated in the original language only.

Solution: Please go to the shipping class in question and change it a little (add or remove a number in the shipping class) and save it, then revert the change and save it again.

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 3 voices.

Last updated by rufusB 1 year, 7 months ago.

Assigned support staff: Alejandro.

Author Posts
June 4, 2019 at 11:10 am #3950777

rufusB

I am trying to: Price shipping by package weight

Link to a page where the issue can be seen: Live site, I can't do that. I currently have to use a flat rate "one price fits all weights" option

I expected to see: two shipping rates, one each for over/under 100g

Instead, I got: Randomly "No option available for your address" or as expected.

June 4, 2019 at 1:58 pm #3952163

Oscar Miras

Hi,

Welcome back to the WPML support team.

On your issue's description, you say that the error happens randomly.

Most of the times happen because of max_input_vars, a PHP variable, is not high enough.

Currently, it is set to 256. Try to increase it to a higher value such as 50000. To change it, you could one of the following:

  • Add or change the line max_input_vars = 50000 in php.ini
  • Add or change the line php_value max_input_vars 50000 in .htaccess

If you wish to know exactly which value should you set here, this information may be useful: https://wpml.org/documentation/getting-started-guide/translating-theme-options/#resolving-issues-with-maxinputvars-value

After making the changes, please check if your MaxInputVars value has been updated in WPML > Support.

Afterwards, please, check if your Shipping Classes and Attributes are translated: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#shipping-classes

I hope it helps. Otherwise, do not hesitate to contact me again.
I will be happy to help.

Kind regards,
Oscar.

June 4, 2019 at 2:22 pm #3952681

rufusB

Hi Oscar, thanks for that, I've set the vars to 50000 and checked it, also that the shipping classes are translated. There are no attributes to translate. Unfortunately that hasn't fixed the problem.

June 4, 2019 at 3:05 pm #3953007

Oscar Miras

Hi,

Thank you for making the changes.

Please, just confirm that you followed the documentation to set the table rate shipping https://wpml.org/documentation/woocommerce-extensions-compatibility/translating-woocommerce-table-rate-shipping-woocommerce-multilingual/

I'm also requesting you temporary access to your WordPress installation. Please, make sure you have a full backup of your site before granting me access. The best way to do it is to create a new user with administrator privileges and share with me the credentials in the provided boxes.

In addition, I would like you to ask for permission to install the Duplicator plugin, in case I need to perform full export of your site to perform more tests in our servers.

Thank you for your collaboration,
Oscar.

June 4, 2019 at 5:26 pm #3954167

rufusB

Table rate shipping extension? Do I need this? I'm using a flat rate, see first screen shot.

June 5, 2019 at 5:06 am #3957087

Oscar Miras

Hi,

My apologies, I misunderstood the list of plugins you were using.

To better understand the problem, please, provide login credentials to access your site.
Besides, because as long as I am concerned this is a production site, I'm asking for permission to install Duplicator plugin so eventually I can export your site and debug the problem in our servers.

Thank you,
Oscar.

June 5, 2019 at 2:31 pm #3961509

Oscar Miras

Hi,

Thank you for your response.
I'm sorry but I would need administrator credentials in order to check some Woocommerce and Woocommerce Multilingual parameters. Please, make sure you have a full backup of your site before granting me access. If possible, create a new administrator user and share with me the credentials in the provided boxes.

In addition, I would like you to ask for permission to install the Duplicator plugin, in case I need to export your site to our servers to better debug the problem.

Thank you for your collaboration,
Oscar.

June 5, 2019 at 2:59 pm #3962033

rufusB

Sorry, forgot to update permissions. That should work now and of course you can install duplicator. Cheers

June 7, 2019 at 7:47 pm #3978883

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, my name is Alejandro,

Since Oscar is currently not available, I will replace him here in the forum.

I hope this is OK with you.

I checked and i could access but i still have a lower-end role (probably subscriptor or the like)

Could you please check again and set it as an administrator?

In the meantime i kindly ask you to please:

1) Ask your hosting to increase your MaxInputVar setting to something over 5000 (right now it's set to 256 which is way too low)

2) Temporarily remove "United Kingdom" as a restriction for the zone region, just so we can try to isolate the issue faster.

Regards.

P.S: if you want to continue this ticket in Spanish, just let me know, i'll happily change languages to make you more comfortable.

June 7, 2019 at 8:11 pm #3978937

rufusB

Hi Alejandro, welcome aboard! I'm ok with English, Spanish or both but English is my first language.

I just changed permissions as there was no sign of Oscar. I've reinstated Admin permissions to the account.

Maxinputvar is currently 50000. Where do you get 256?

I'm not sure what you mean about United kingdom restrictions. Now you have admin permissions, if you are not going to clone the site, best if you modify the settings as you need them, but please let me know of all changes you make.
Cheers

June 10, 2019 at 8:29 am #3985843

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

For now scratch all i said, let's try to start over, just so i avoid confusing you.

With the actual settings. i staged a normal purchase and i noticed the shipping was added (i tried international with Italy and domestic with UK, both worked) , the only thing i did so far was cleaning the cache.

Can you tell me if i should do something else?

I did notice there was another weight base flat shipping disabled, but that shipping didn't even have a cost, so it would've always been a free shipping.

Please let me know just so i can figure out how to proceed.

June 10, 2019 at 8:47 am #3985949

rufusB

Hi, the current settings do work, but they don't differentiate between different weights. This is problematic for me as my products' shipping weight varies, just under/over 100g and 100g is the limit of my postal service's charge band for all postal zones. The current rate is an average, which overcharges for CDs up to 100g and undercharges for those over 100g.

The deactivated settings in all postal zones are "post by weight" and these are the settings I want to use. These should charge postage by the weight in the product variation. This flat rate works in English and in some translations but many of these don't translate for some reason. In these cases the customer is told "No option available for your address." This is the problem.

June 10, 2019 at 9:43 am #3986313

rufusB

here's an example. I'm not sure if one can assume that this will work in a real purchase but you'll see here that the shipping class has translated while the weight hasn't. On many products the shipping class field doesn't even appear in the translation.

Here's a product, also a CD with no current digital variations, where the product shipping class and weight fields don't appear for translation- hidden link

June 10, 2019 at 11:51 am #3987255

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Let's do this. can you please add a cost to the shipping, first of all, otherwise it will always show either 0 or it might not show at all.

Second of all, can you replicate the problem on your end and then give me the steps so i can do the same? please be as detailed as you can because it's often in the details where the clues to solve these issues are hidden.

the steps will help me figure out not only how can i replicate the problem but also if there's a problem in the workflow or in the logic of the process or, of course, if the problem is somewhere else (and it will allow me to spot them faster)

Thanks.

June 10, 2019 at 11:56 am #3987267

rufusB

As far as I'm aware, all the shipping options, active and not active, have costs. Where are you seeing no cost?